Gazebo | Ignition | Community
Ask Your Question

Problem with the packet of ROS Hydro

asked 2014-08-07 07:27:21 -0600

updated 2014-08-11 10:11:27 -0600

I'm using the ROS packet of Gazebo:

sudo apt-get install ros-hydro-gazebo-ros-pkgs ros-hydro-gazebo-ros-control

But have problems when used:

rosrun gazebo_ros gazebo


roscd: no se encontró la orden
rosmake: no se encontró la orden

I have included this instruction in the .bashrc

source /opt/ros/hydro/setup.bash

When use "cd" and "make", example:

cd ~/NAO/nao_gazebo_plugin
~/NAO/nao_gazebo_plugin$ make
make: *** No se especificó ningún objetivo y no se encontró ningún makefile.  Alto.

I don't have problems with:

rosws init
rosws set

I want to know how I can solve this problems

A lot of thanks!!

edit retag flag offensive close merge delete


vncntmh gravatar imagevncntmh ( 2014-08-10 08:24:29 -0600 )edit

The link you posted makes no reference to the now outdated rosmake command. Did the apt-get command above work?

joq gravatar imagejoq ( 2014-08-13 10:48:10 -0600 )edit

2 Answers

Sort by » oldest newest most voted

answered 2014-08-13 15:56:17 -0600

Jose Luis Rivero gravatar image

Could you try the following:

apt-get install ros-hydro-ros
. /opt/ros/hydro/setup.bash

And if this is not working, please use to copy the content of:



edit flag offensive delete link more


A lot of Thank!! The problem is Solved!! :)

vncntmh gravatar imagevncntmh ( 2014-08-19 08:25:38 -0600 )edit

answered 2014-08-09 08:27:18 -0600

Henrique Nery gravatar image

Did you make source /opt/ros/hydro/setup.bash?

Normally you cant use those commands if you forget it. As said in tutorial, i suggest you to put it in .bashrc, so it will be done automatically every time you open a terminal.

Best Regards, Henrique

edit flag offensive delete link more


Hello! I have using this instruction and it's included into .bashrc.

A lot fo thankes!!

vncntmh gravatar imagevncntmh ( 2014-08-10 08:22:38 -0600 )edit

It's solved or not?

Henrique Nery gravatar imageHenrique Nery ( 2014-08-10 09:26:10 -0600 )edit

I had already using this instruction and its included into .bashrc.

And the problem continues.

vncntmh gravatar imagevncntmh ( 2014-08-11 09:48:10 -0600 )edit
Login/Signup to Answer

Question Tools


Asked: 2014-08-07 07:27:21 -0600

Seen: 819 times

Last updated: Aug 13 '14