Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thanks for the suggestions. I am using the following settings:

<physics name='default_physics' default='0' type='ode'>
  <real_time_update_rate>1000</real_time_update_rate>
  <max_step_size>0.0005</max_step_size>
  <real_time_factor>0.3</real_time_factor>
</physics>

I need the step size to be 0.0005 or better to synchronize the sensors correctly. I have changed the real_time_factor both up and down, and it does not help.

The example at: http://sdformat.org/spec?ver=1.6&elem=physics shows the following,

  <ode>
    <solver>
      <type>quick</type>
      <iters>50</iters>
      <sor>1.4</sor>
    </solver>
    <constraints>
      <cfm>0</cfm>
      <erp>1</erp>
      <contact_max_correcting_vel>0</contact_max_correcting_vel>
      <contact_surface_layer>0</contact_surface_layer>
    </constraints>
  </ode>

but I can't find documentation on what the tags mean.

Related to this problem, I ran the above sim for about 14 hours, generating about 100 frames. At that point the sim died with the following warning messages:

[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/local/info, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/physics/contacts, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/info, deleting message. This warning is printed only once. Killed

What is going on?

Thanks for the suggestions. I am using the following settings:

<physics name='default_physics' default='0' type='ode'>
  <real_time_update_rate>1000</real_time_update_rate>
  <max_step_size>0.0005</max_step_size>
  <real_time_factor>0.3</real_time_factor>
</physics>

I need the step size to be 0.0005 or better to synchronize the sensors correctly. I have changed the real_time_factor both up and down, and it does not help.

The example at: http://sdformat.org/spec?ver=1.6&elem=physics shows the following,

  <ode>
    <solver>
      <type>quick</type>
      <iters>50</iters>
      <sor>1.4</sor>
    </solver>
    <constraints>
      <cfm>0</cfm>
      <erp>1</erp>
      <contact_max_correcting_vel>0</contact_max_correcting_vel>
      <contact_surface_layer>0</contact_surface_layer>
    </constraints>
  </ode>

but I can't find documentation on what the tags mean.

Related to this problem, I ran the above sim for about 14 hours, generating about 100 frames. At that point the sim died with the following warning messages:

[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/local/info, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/physics/contacts, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/info, deleting message. This warning is printed only once. Killed

What is going on?

Thanks As usual, the answer for the suggestions. my immediate problem was simple.

I am using the following settings:

changed the sensor type to "gpu_ray" and the physics tags to the following.

<sdf version="1.6"> <physics name='default_physics' default='0' type='ode'> <real_time_update_rate>1000</real_time_update_rate> <max_step_size>0.0005</max_step_size> <real_time_factor>0.3</real_time_factor> type="ode"> <max_step_size>0.05</max_step_size> <real_time_factor>0.2</real_time_factor> <real_time_update_rate>1</real_time_update_rate> <ode> <solver> <type>quick</type> <iters>2</iters> <sor>1.4</sor> </solver> <constraints> <cfm>0</cfm> <erp>1</erp> <contact_max_correcting_vel>0</contact_max_correcting_vel> <contact_surface_layer>0</contact_surface_layer> </constraints> </ode> </physics>

I need the step size </sdf>

With the changes, everything worked fine, and the entire simulation executed in about 5 minutes (as opposed to be 0.0005 or better to synchronize the sensors correctly. I have changed the real_time_factor both up and down, and than one day before it does not help.

Related to this problem, I ran the above sim for about 14 hours, generating about 100 frames. At that point the sim died with the following warning messages:

[Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/local/info, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/physics/contacts, deleting message. This warning is printed only once. [Wrn] [Publisher.cc:141] Queue limit reached for topic /gazebo/animated_box_world/pose/info, deleting message. This warning is printed only once. Killed

What is going on?

crashed).