Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

the height of bounce was not change at all.

Sorry, I think I'm misunderstanding your questio. Is the ball:

  1. Not bouncing
  2. Bouncing but not losing energy
  3. Bouncing... but the initial bounce height is unaffected by restitution_coefficient

I'm assuming the answers is 3 (correct me if I'm confused).

Have you tried increasing max_vel to 10-20 m/s? Setting max_vel too low (default value is 0.01 m/s) might be the cause.

This Gazebo answer on changing bounce properties may be useful to you.

the height of bounce was not change at all.

Sorry, I think I'm misunderstanding your questio. Is the ball:

  1. Not bouncing
  2. Bouncing but not losing energy
  3. Bouncing... but the initial bounce height is unaffected by restitution_coefficient

I'm assuming the answers answer is 3 (correct me if I'm confused).

Have you tried increasing max_vel to 10-20 m/s? Setting max_vel too low (default value is 0.01 m/s) might be the cause.

This Gazebo answer on changing bounce properties may be useful to you.

the height of bounce was not change at all.

Sorry, I think I'm misunderstanding your questio. question. Is the ball:

  1. Not bouncing
  2. Bouncing but not losing energy
  3. Bouncing... but the initial bounce height is unaffected by restitution_coefficient

I'm assuming the answer is 3 (correct me if I'm confused).

Have you tried increasing max_vel to 10-20 m/s? Setting max_vel too low (default value is 0.01 m/s) might be the cause.

This Gazebo answer on changing bounce properties may be useful to you.

the height of bounce was not change at all.

Sorry, I think I'm misunderstanding your question. Is the ball:

  1. Not bouncing
  2. Bouncing but not losing energy
  3. Bouncing... but the initial bounce height is unaffected by restitution_coefficient

I'm assuming the answer is 3 (correct me if I'm confused).

Have you tried increasing max_vel to 10-20 m/s? Setting max_vel too low (default value is 0.01 m/s) might be the cause.

This Gazebo answer on changing bounce properties may be useful to you.

edit: I glanced at your .world file. Couple things I noticed:
1) lines 31-32

 <mu>100000</mu>
 <mu2>-1000</mu2>

Set <mu> and <mu2> to more reasonable (& positive values) like 1.0 and 1.0.

2) line 27

 <restitution_coefficient>0</restitution_coefficient>

You'll want <restitution_coefficient> to be > 0