Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Mind you that this snippet:

<physics type='ode'>
  <max_step_size>0.001</max_step_size>
  <real_time_factor>1</real_time_factor>
  <real_time_update_rate>1000</real_time_update_rate>
  <gravity>0 0 -9.8</gravity>
</physics>

is also Gazebo's default setting. The reason your RTF still goes below 1 is because your machine cannot handle it. Step size and update rate are pretty set in stone after they've been set. Real time factor however will be lowered if the machine cannot handle computing with the given parameters.

If you'd like achieve a real time factor of 1, you can follow the advice of linus111 and lower max_step_size and/or realt_time_update_rate. Note that this might change how certain elements behave in the Gazebo world as far as physics is conerned.