Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

After almost 2 days of digging into this issue, I finally managed to get the kinect sensor in Gazebo publish its topics (and see the point cloud in rviz), horray!

I "just" had to upgrade my Gazebo 7.0.0 to 7.11 (follow the alternative step-by-step-installation here (you can do that even if you already have Gazebo & ROS installed). After that, following the tutorial and the answer from from malhar worked quite well.

If you have the same issue, please also check if you have installed the plugin packages and the gazebo_ros packages

sudo apt install ros-kinetic-gazebo-plugins ros-kinetic-gazebo-ros-pkgs ros-kinetic-gazebo-ros-control

in order to have the /opt/ros/kinetic/lib/libgazebo_ros_openni_kinect.so file and the gazebo-ros-bindings.

Just FYI: I'm running ROS Kinetic with Gazebo 7 (7.11) on Ubuntu 16.04 (on a VM with Oracle VM VirtualBox, which runs on a Win10 host). I got my solution from this site (quite at the bottom of the page). It seems there was a bug with Gazebo 7.0.0 inside VMs, which then got resolved in a later version of Gazebo 7. Other solutions I tried can be found here, here, here or here, in case my solution still doesn't solve your problem.