Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hello,

I found a solution and I'm pretty sure it is a problem of path.

When I was creating my world with Gazebo, I get this Insert tab: image description

I inserted my modified models from /home/username/model_editor_models(green arrow, 2nd picture) and it creates the problem mentionned above.

When I was running a simulation, I tried to add an another Iris model. I discover that the one in my world was coming from the folder /home/username/Firmware/Tools/sitl_gazebo/models. image description

So I tried to put my modified models in this folder. To be able to insert my model, I had to launch my simulation otherwise I didn't get the right folder (red arrow) to insert my models. Then I save the world and change it in my launch files.

Now when I used rosrun rqt_image_view rqt_image_view, I have my models with the right texture.

I hope it could help you if you have the same problem even if it is not a clean solution (or maybe yes). If someone have a precise response or explanation, I would appreciate his contribution.

Best regards :)