Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

I have meet such issue because I tried to install gazebo from source. The main season is that libgazebo_ros_api_plugin.so is trying to use gazebo::msgs::WorldStatistics which is not provided. That is, it does not link to all "libgazebo_msgs.so...." files. The thing you can do is delete gazebo7 completely and reinstall it with apt-get. Then it will solve the issue.