Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Firstly, thanks for your answers.

I have already searched for the plugin in that folders but it was not exist.

@BillThePlatypus said "the plugin is for gazebo10" than i think the plugin doesn't exist on gazebo9 https://answers.gazebosim.org//question/23776/gazebo-static-map-plugin-not-loading/

but i saw the repo including the plugin with @Veerachart 's answer.

so, i expected, my system doesn't allowed to install packages from packages.osrfoundation.org.

i watched those steps to get plugin:

1.Setup my computer to accept software from packages.osrfoundation.org.

sudo sh -c 'echo "deb http://packages.osrfoundation.org/gazebo/ubuntu-stable lsb_release -cs main" > /etc/apt/sources.list.d/gazebo-stable.list'

  1. update packages

sudo apt-get update

  1. tried to open gazebo but i have faced with a problem:

gazebo: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgazebo_common.so.9: undefined symbol: _ZN8ignition10fuel_tools12ClientConfig12SetUserAgentERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

  1. upgraded the libraries with

sudo apt upgrade libignition-math2

  1. than tried to run gazebo and it worked well

gazebo --verbose static_map_plugin.world

Thanks everyone, these are my experiences. I hope it can help others.