Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

I met the same problem, no matter how I adjust the parameters mu1 and mu2, it doesn't work. Actually this is not a problem caused by the friction parameter setting, when I set the D parameter of the PID controller for each joint from 10 to 1, the problem disappeared. I used effort_controllers/JointPositionController, I think this will help you.