Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

pcl/conversions.h is part of PCL, but you need PCL version 1.7 to build against this.

There is a hydro package for PCL 1.7.0-rc2 called ros-hydro-pcl. If you install/upgrade that package (sudo apt-get install ros-hydro-pcl) it should fix your problem.

The pcl_conversions package, which the gazebo_ros_pkgs depends on now has a versioned dependency on PCL, so this shouldn't happen in the future:

https://github.com/ros-perception/pcl_conversions/commit/b4071f4aa65e9a32908b2dacbdc8e15362d1209b#L1R23