Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I figured out.

The problem is that gazebo and ROS does not have syncronized time.

I published gazebo's simulation time into ROS as '/clock'.

And I set ROS parameter 'use_sim_time' into ture.

It is worth to read: http://www.ros.org/wiki/Clock

I figured out.

The problem is that gazebo and ROS does not have syncronized time.

I published gazebo's simulation time into ROS as '/clock'.

And I set ROS parameter 'use_sim_time' into ture. true.

There is no more error and finally PR2 works with ROS and Gazebo-1.3.

It is worth to read: http://www.ros.org/wiki/Clock