Gazebo | Ignition | Community
Ask Your Question

Error while loading shared libraries:

asked 2013-01-25 17:45:28 -0500

amit gravatar image

After installation version 1.3 when I am trying to run the program with command ; gazebo

I am getting the following error :

gazebo: error while loading shared libraries: cannot open shared object file: No such file or directory

Please suggest what to do now....

edit retag flag offensive close merge delete


Please provide some details -- installation method (binary/source), output of locate and env | grep -i gazebo. Though, it may be sufficient to run sudo ldconfig in some cases...

Boris gravatar imageBoris ( 2013-01-27 08:36:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-01-27 19:13:03 -0500

Boris gravatar image

Looks like some environment variables are missing/wrong. In case you didn't change the CMAKE_INSTALLATION_PREFIX you have to source the file from /usr/local/share/gazebo-1.4/. If gazebo is installed in another folder, then you need to add the following lines to your .bashrc:

export LD_LIBRARY_PATH=<install_path>/local/lib:$LD_LIBRARY_PATH
export PATH=<install_path>/local/bin:$PATH
export PKG_CONFIG_PATH=<install_path>/local/lib/pkgconfig:$PKG_CONFIG_PATH
source <install_path>/share/gazebo-1.4/

where <install_path> is the same with CMAKE_INSTALLATION_PREFIX specified during build configuration (see Step 10 in Wiki). After that reopen the terminal or manualy source the .bashrc with

$ source .bashrc

edit flag offensive delete link more


Thank you very much ... I finally solved the probelm.

amit gravatar imageamit ( 2013-01-27 19:27:07 -0500 )edit

But when I close the terminal and try to launch gazebo again I get the same error message. So each time I have to source it. Since I am using the default directory /usr/local , I use the 2nd command given in Step 10 in wiki. How can I get this solved ?

amit gravatar imageamit ( 2013-01-27 19:36:11 -0500 )edit

Simply add `source /usr/local/share/gazebo-1.4/` to the end of your `~/.bashrc` file.

Boris gravatar imageBoris ( 2013-01-27 19:41:40 -0500 )edit

Alright ... thanks again.

amit gravatar imageamit ( 2013-01-27 19:49:15 -0500 )edit

Please also consider to mark the answer as correct if it did help you :)

Boris gravatar imageBoris ( 2013-01-28 04:34:21 -0500 )edit

I also have the same problem, this the location of my instalation files LD_LIBRARY_PATH=/usr/local/lib/gazebo-1.8/plugins:/usr/local/lib/gazebo-1.8/plugins: GAZEBO_RESOURCE_PATH=/usr/local/share/gazebo-1.8:/usr/local/share/gazebo_models GAZEBO_MASTER_URI=http://localhost:11345 GAZEBO_PLUGIN_PATH=/usr/local/lib/gazebo-1.8/plugins GAZEBO_MODEL_DATABASE_URI= I have followed the answer but I still get the error: gazebo: error while loading shared libraries: libgazebo_com

Hugo Siles gravatar imageHugo Siles ( 2013-06-11 17:29:21 -0500 )edit

@Hugo Siles, please create a new question, so the others can see it quickly. Otherwise only those to participate in the discussion here will be notified. P.S. a similar question was recently asked [here](

Boris gravatar imageBoris ( 2013-06-12 21:21:39 -0500 )edit

answered 2013-01-27 12:55:36 -0500

amit gravatar image

@Boris : I installed using source (mercurial). After reading your comment I ran sudo ldconfig command first and then ran the gazebo to finally launch it. I am getting the following error :

Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.

Error [] Could not open file[worlds/]
Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.

Msg Waiting for master.
Error [] Connection Manager is not running
edit flag offensive delete link more



Please do not use answer form unless you have a correct answer to your own question. To provide additional information or to show intermediate results edit the question. For discussions please use comments.

Boris gravatar imageBoris ( 2013-01-27 19:30:21 -0500 )edit

Question Tools


Asked: 2013-01-25 17:45:28 -0500

Seen: 9,304 times

Last updated: Jan 27 '13