Gazebo | Ignition | Community
Ask Your Question

After updating Gazebo to 1.3 under Groovy I get an Ogre Plugin error

asked 2013-01-30 05:03:16 -0500

AndreiHaidu gravatar image


I am using ROS Groovy and I updated Gazebo to 1.3 (binary version), under Ubuntu 12.04.

For testing it I got a simple

<?xml version ='1.0'?>
<sdf version ='1.3'>
  <world name='default'>



After I source:

/opt/ros/groovy/stacks/simulator_gazebo/gazebo/gazebo/share/gazebo-1.3/ /opt/ros/groovy/stacks/simulator_gazebo/gazebo/setup.bash

and run gzserver:

rosrun gazebo gzserver ~/../worlds/

I got the following error msg:

Error [] Unable to load Ogre Plugin[/opt/ros/groovy/stacks/visualization_common/ogre/ogre/lib/OGRE/RenderSystem_GL]. Rendering will not be possible.Make sure you have installed OGRE and Gazebo properly.
Error [] Failed to load the Rendering engine subsystem
unable to find OpenGL rendering system. OGRE is probably installed incorrectly. Double check the OGRE cmake output, and make sure OpenGL is enabled.

Did something happen to the OpenGL libraries during the update, or is this a bug?

Thanks, Andrei

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted

answered 2013-02-05 04:45:04 -0500

AndreiHaidu gravatar image

updated 2013-02-18 03:06:29 -0500

Solution: in

I had to change the OGRE_RESOURCE_PATH to:
export OGRE_RESOURCE_PATH=/usr/lib/x86_64-linux-gnu/OGRE-1.7.4

UPDATE: according to @Ryan:

on Ubuntu 11.10, change OGRE_RESOURCE_PATH to /usr/lib/OGRE in both



edit flag offensive delete link more

answered 2013-02-16 09:01:05 -0500

Ryan gravatar image

I'm on Ubuntu 11.10 at the moment. I needed to change OGRE_RESOURCE_PATH to /usr/lib/OGRE in both




edit flag offensive delete link more


Thanks, it helped.

ZdenekM gravatar imageZdenekM ( 2013-05-14 06:37:40 -0500 )edit

answered 2013-02-02 11:41:04 -0500

Alex Buyval gravatar image

Hi, Andrei

I had the same error too. I have found that OGRERESOURCEPATH was not correct. There was a row

export OGRE_RESOURCE_PATH=/usr/lib/x86_64-linux-gnu/OGRE-1.7.4

in file /opt/ros/groovy/stacks/simulatorgazebo/gazebo/scripts/ However, folder [x8664-linux-gnu] is empty on my computer. I have found OGRE-1.7.4 in folder [/usr/lib/i386-linux-gnu], so I replace the row on following row:

export OGRE_RESOURCE_PATH=/usr/lib/i386-linux-gnu/OGRE-1.7.4

Now I have not this error.

Best Regards, Alex

edit flag offensive delete link more


Hi Alex, thanks for answering, for me the solution it doesn't work. I actually have the libraries in x86_64-linux-gnu/OGRE-1.7.4. I will try a reinstall.

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-05 03:25:47 -0500 )edit

I figured it out thanks to your answer, I had a different path in the, which changed with the update. And I guess you had to change it to i386-linux-gnu because you are running on 32 bits.

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-05 04:47:08 -0500 )edit

Thanks! Works for 32 bit 12.04 Ubuntu

destogl gravatar imagedestogl ( 2013-04-08 03:07:28 -0500 )edit

answered 2013-02-14 15:05:52 -0500

Davide Zanin gravatar image

updated 2013-02-14 15:06:14 -0500

The solution doesn't work for me!

(sorry but I can't comment the answer (low karma??))

edit flag offensive delete link more


Do you get the same error? Did this happen after updating from Gazebo 1.2.5 to 1.3 ? (Just to be clear which solution did you try? As there are 2, and only the one marked with green is the one that worked for me). Cheers

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-14 15:28:38 -0500 )edit

Yes I get the same error with Gazebo 1.3. I used the second solution (export OGRERESOURCEPATH=/usr/lib/i386-linux-gnu/OGRE-1.7.4) because I have a 32 bit system

Davide Zanin gravatar imageDavide Zanin ( 2013-02-15 06:55:14 -0500 )edit

Could you tell me what is written in your "/opt/ros/groovy/stacks/simulatorgazebo/gazeb/setup.bash" file at the line with 'OGRERESOURCEPATH'? And in the terminal what does '$ echo $OGRERESOURCE_PATH' say?

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-15 07:55:18 -0500 )edit

In file /opt/ros/groovy/stacks/simulatorgazebo/gazebo/setup.bash export OGRERESOURCE_PATH=rospack find ogre/ogre/lib/OGRE

echo $OGRERESOURCEPATH returns <pre>/opt/ros/groovy/stacks/visualization_common/ogre/ogre/lib/OGRE<code>

Thank you!

Davide Zanin gravatar imageDavide Zanin ( 2013-02-15 09:18:13 -0500 )edit

That means you did not change the paths as the answer says. Go to the setup.bash file, open it with sudo rights, change the path to the one you have (most probably export OGRERESOURCEPATH=/usr/lib/i386-linux-gnu/OGRE-1.7.4 if you are running on 32 bits) then source the file ( in the terminal: '$ source setup.bash' )

AndreiHaidu gravatar imageAndreiHaidu ( 2013-02-15 10:13:28 -0500 )edit

Sorry I post the original file, I doing the change, now in the file I have export OGRERESOURCEPATH=/usr/lib/i386-linux-gnu/OGRE-1.7.4/ and echo $OGRERESOURCEPATH returns /usr/lib/i386-linux-gnu/OGRE-1.7.4/ but doesn't working

Davide Zanin gravatar imageDavide Zanin ( 2013-02-15 13:37:46 -0500 )edit

Thank you @Ryan, your solution working!

Davide Zanin gravatar imageDavide Zanin ( 2013-02-18 02:17:24 -0500 )edit

Question Tools



Asked: 2013-01-30 05:03:16 -0500

Seen: 2,826 times

Last updated: Feb 18 '13