Gazebo | Ignition | Community
Ask Your Question

Gazebo shuts down immediately

asked 2013-02-05 01:49:19 -0500

anonymous user



I installed Gazebo 1.4.0 on Ubuntu 12.04 using apt-get at first and also compiling from source. The problem that I'm facing is that when I type in the 'gazebo' command, it shows the GUI for a second and then immediately shuts it down without giving any errors. What is the problem?

edit retag flag offensive close merge delete


Did you follow the step 5 of ?

Daniel Vaz gravatar imageDaniel Vaz ( 2013-02-05 04:12:42 -0500 )edit

Yes I did. Does anyone have a working 1.4.0 version on Ubuntu 12.04?

siddharth950 gravatar imagesiddharth950 ( 2013-02-05 06:54:41 -0500 )edit

I got it working! I installed a new copy of Ubuntu 12.04 and installed using sudo apt-get. It's working fine.

siddharth950 gravatar imagesiddharth950 ( 2013-02-06 12:05:29 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted

answered 2013-02-06 13:06:21 -0500

treanorj gravatar image

Hi all, firstly, let me apologise for writing this as an 'answer', I don't have enough Karma yet to post as a comment. I am in the same boat as the user above, and have been for a couple of weeks. I spent some time going through other posts, questions and answers looking for how to resolve this. I have tried various combinations of un-installing and reinstalling both ROS and Gazebo. Also, I have tried both 1.3 and 1.4 source installations, as well as the standard repository edition. The environment variables you asked for @nkoenig are as follows:

<user>@XPS-Ubuntu:~$ env | grep GAZEBO

I have also triple checked paths and the like. Any suggestions would be very welcome as I would rather not have to do an OS reinstall as others have done to fix various issues.

If gazebo is called, the program crashes without an errors, sometimes it will get as far as the UI which will then go dark and crash, again without any errors. If gzclient is called after a successful gzserver or if gzmaster is called alone, we get the same result.

Thanks in advance and please let me know if there are further details you require. Again, sorry for posting this here in this format, however, I thought it better than starting a new question about the same issue.

edit flag offensive delete link more


What is the output of: glxinfo | grep "direct rendering:"

nkoenig gravatar imagenkoenig ( 2013-02-06 14:48:00 -0500 )edit

@nkoenig Hi, thanks for the quick reply. The output is: direct rendering: Yes

treanorj gravatar imagetreanorj ( 2013-02-07 07:53:28 -0500 )edit

can you open two terminals. In one terminal run `gdb gzserver` and in the other `gdb gzclient`. When gzclient fails, type `bt` at the gdb prompt. Post the out of the `bt` command.

nkoenig gravatar imagenkoenig ( 2013-02-07 09:08:01 -0500 )edit

Ok, so I have gdb gzserver happily working away in the first terminal, and in the second, I have gdb gzclient however while no gazebo comes up there does not seem to be a specified failure. When I type bt I get "No stack".

treanorj gravatar imagetreanorj ( 2013-02-07 10:35:08 -0500 )edit

What happens when you just run gzclient in a terminal. Make sure that no gzserver is running.

nkoenig gravatar imagenkoenig ( 2013-02-07 11:23:50 -0500 )edit

Running gzserver alone waits at the Msg Waiting for master line

treanorj gravatar imagetreanorj ( 2013-02-07 11:37:20 -0500 )edit

Did you mean "Running gzclient"?

nkoenig gravatar imagenkoenig ( 2013-02-07 11:43:59 -0500 )edit

Yes, sorry, I mean running `gzclient`

treanorj gravatar imagetreanorj ( 2013-02-07 11:48:41 -0500 )edit

Can you try running the gzserver worlds/ in one terminal, and in another terminal: gztopic view /gazebo/default/pr2/head_tilt_link/head_mount_sensor/image? The gztopic view command should open a window with a greyscale image.

nkoenig gravatar imagenkoenig ( 2013-02-07 12:17:16 -0500 )edit

Before I get to the gztopic point, after I start gzserver worlds/ I get the usual Msg Waiting for masterMsg Connected to gazebo master @ <a href=""> Publicized address:

Then multiple lines of the same warning: Warning [] joint friction not implemented Which finishes then with a Segmentation fault (core dumped)

Apologies in the format of my replies, I don't know fully the wiki syntax.

treanorj gravatar imagetreanorj ( 2013-02-07 12:29:00 -0500 )edit

answered 2013-02-05 11:28:47 -0500

nkoenig gravatar image

Can you post the output of:

env | grep GAZEBO
edit flag offensive delete link more

answered 2013-02-08 13:21:14 -0500

treanorj gravatar image

@nkoenig So here is the output you requested in the final comment above.#0 0x00007fd3ee2ad307 in ?? () from /usr/lib/fglrx/dri/

#1 0x00007fd3ee32310e in ?? () from /usr/lib/fglrx/dri/

#2 0x00007fd3ee323449 in ?? () from /usr/lib/fglrx/dri/

#3 0x00007fd3ed836421 in ?? () from /usr/lib/fglrx/dri/

#4 0x00007fd3ed7430b8 in ?? () from /usr/lib/fglrx/dri/

#5 0x00007fd3ed8a25b7 in ?? () from /usr/lib/fglrx/dri/

#6 0x00007fd3edbc283d in ?? () from /usr/lib/fglrx/dri/

#7 0x00007fd3e3a40a20 in Ogre::GLRenderSystem::bindGpuProgram ( this=0x7fd3ec9eaa58, prg=<optimized out>) at /build/buildd/ogre-1.7.4/RenderSystems/GL/src/OgreGLRenderSystem.cpp:3018

#8 0x00007fd3fc81e5e5 in Ogre::SceneManager::_setPass (this=0x7fd3eca96358, pass=0x7fd3eca78848, evenIfSuppressed=<optimized out>, shadowDerivation=true) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:942

#9 0x00007fd3fc819269 in visit (rp=0x7fd3eca0d858, this=0x7fd3eca9ad30) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:2872

#10 Ogre::SceneManager::SceneMgrQueuedRenderableVisitor::visit ( this=0x7fd3eca9ad30, rp=0x7fd3eca0d858) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:2860

#11 0x00007fd3fc7d0d59 in Ogre::QueuedRenderableCollection::acceptVisitorDescending (this=<optimized out>, visitor=0x7fd3eca9ad30) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderQueueSortingGrouping.cpp:---Type <return> to continue, or q <return> to quit--- 465

#12 0x00007fd3fc7d0e01 in Ogre::QueuedRenderableCollection::acceptVisitor ( this=<optimized out>, visitor=<optimized out>, om=<optimized out>) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderQueueSortingGrouping.cpp:421

#13 0x00007fd3fc8197bc in Ogre::SceneManager::renderBasicQueueGroupObjects ( this=0x7fd3eca96358, pGroup=0x7fd3ec4eb0b8, om=Ogre::QueuedRenderableCollection::OM_PASS_GROUP) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:3027

#14 0x00007fd3fc8189e7 in Ogre::SceneManager::renderVisibleObjectsDefaultSequence (this=0x7fd3eca96358) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:2281

#15 0x00007fd3fc81d184 in Ogre::SceneManager::_renderScene ( this=0x7fd3eca96358, camera=0x7fd3e0a00380, vp=0x7fd3ec5db428, includeOverlays=<optimized out>) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp:1505

#16 0x00007fd3fc6846ec in Ogre::Camera::_renderScene (this=0x7fd3e0a00380, vp=0x7fd3ec5db428, includeOverlays=true) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreCamera.cpp:412

#17 0x00007fd3fc7e99f8 in Ogre::RenderTarget::_updateViewport ( this=0x7fd3e0a0de80, viewport=0x7fd3ec5db428, updateStatistics=true) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderTarget.cpp:146

#18 0x00007fd3fc7e991b in Ogre::RenderTarget::_updateAutoUpdatedViewports ( ---Type <return> to continue, or q <return> to quit--- this=0x7fd3e0a0de80, updateStatistics=true) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderTarget.cpp:124

#19 0x00007fd3fc7e93be in Ogre::RenderTarget::updateImpl (this=0x7fd3e0a0de80) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderTarget.cpp:101

#20 0x00007fd3fc7e995c in Ogre::RenderTarget::update (this=0x7fd3e0a0de80, swap=false) at /build/buildd/ogre-1.7.4/OgreMain/src/OgreRenderTarget.cpp:541

#21 0x00007fd4006871b8 in gazebo::rendering::Camera::RenderImpl() () from /usr/lib/

#22 0x00007fd400687236 in gazebo::rendering::Camera::Render() () from /usr/lib/

#23 0x00007fd4041ac309 in gazebo::sensors::CameraSensor::UpdateImpl(bool) () from /usr/lib/

#24 0x00007fd4041c66c8 in gazebo::sensors::Sensor::Update(bool) () from /usr/lib/

#25 0x00007fd4041cc61b in gazebo::sensors::SensorManager::Update(bool) () from /usr/lib/

#26 0x0000000000422cea in gazebo::Server::Run() ()

#27 0x000000000041f8f9 in main ()

edit flag offensive delete link more



Hi, the error with fglrx_dri is likely due to ati proprietary gpu driver incompatibility with openGL, can you try one of the free gpu driver alternatives?

hsu gravatar imagehsu ( 2013-02-08 17:37:15 -0500 )edit

Hi. really sorry for the very late reply. I believe you are completely right about the drivers. I have not had time the last few days to change over drivers to see if it will help. I am working off another machine now with no problems (Nvidia). I will post back in a couple of days when I actually manage to swap over those drivers.

treanorj gravatar imagetreanorj ( 2013-02-11 12:46:09 -0500 )edit

i have same error! lenovo r500 and ATI Mobility Radeon HD 3400 Series >> what am i should to0 do0? i am beginner. how can i get this "free gpu driver alternatives"? help plz...

Mohsen Hk gravatar imageMohsen Hk ( 2013-03-19 20:07:01 -0500 )edit

answered 2013-02-07 17:25:44 -0500

arkamar gravatar image

updated 2013-02-07 17:26:59 -0500

Hi, I had installed Gazebo-1.4.0 to Gentoo from a source code on computer with architecture x86_64 and everything works well.

Then I tried to compile it to a computer with architecture x86. I have same problem as Anonymous and treanorj at this architecture (gzclient quits with Segmentation fault). I think that the problem is with, because of PIC (Position Independent Code), which should explain this warning.

Building CXX object gazebo/gui/CMakeFiles/gazebo_gui.dir/qrcresources.cxx.o Linking CXX shared library /usr/lib/gcc/i486-pc-linux-gnu/4.6.3/../../../../i486-pc-linux-gnu/bin/ld: CMakeFiles/gazebo_gui.dir/__/ warning: relocation in readonly section `.text.startup'. /usr/lib/gcc/i486-pc-linux-gnu/4.6.3/../../../../i486-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in a shared object.

edit flag offensive delete link more

answered 2013-02-05 13:03:09 -0500

nkoenig gravatar image

I was able to reproduce this problem by upgrading ubuntu after installing gazebo by:

sudo apt-get update; sudo apt-get upgrade

Then the problem was fixed shortly there after with another:

sudo apt-get update; sudo apt-get upgrade

Could you try updating and upgrading your system?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools



Asked: 2013-02-05 01:49:19 -0500

Seen: 3,502 times

Last updated: Feb 08 '13