libgazebo_player not installed via ubuntu repository

asked 2015-12-04 09:52:52 -0600

davinellulinvega gravatar image

Hello everyone,

I am quite new to both gazebo and player and yet I am already trying to have the both of them communicate. I installed gazebo 6.1.0 through the script provided on the website. And compiled and installed player 3.1.0 from the svn sources. However, when I am trying to run a simple pioneer2dx, the gzserver is find ,but player outputs an error:

player position2d.cfg 
Player v.3.1.0-svn

* Part of the Player/Stage/Gazebo Project [http://playerstage.sourceforge.net].
* Copyright (C) 2000 - 2013 Brian Gerkey, Richard Vaughan, Andrew Howard,
* Nate Koenig, and contributors. Released under the GNU General Public License.
* Player comes with ABSOLUTELY NO WARRANTY.  This is free software, and you
* are welcome to redistribute it under certain conditions; see COPYING
* for details.

error   : Failed to load plugin libgazebo_player.
error   : libtool reports error: file not found
error   : plugin search path: /home/davinellulinvega/Downloads:/home/davinellulinvega/Downloads:/usr/lib/player-3.1/:/usr/lib/
error   : failed to load plugin: libgazebo_player
error   : failed to parse config file /home/davinellulinvega/Downloads/position2d.cfg driver blocks

The player configuration file is:

driver
(
  name "gazebo"
  provides ["simulation:0"]
  plugin "libgazebo_player"

  # The name of a running Gazebo world, specified in a .world file
  world_name "default"
)

driver
(
  name "gazebo"
  provides ["position2d:0"]

  # This name must match the name of a model in the "default" world
  model_name "pioneer2dx"
)

As for the gazebo world it is:

<?xml version="1.0" ?>
<sdf version="1.5">
  <world name="default">
    <!-- Ground -->
    <include>
      <uri>model://ground_plane</uri>
    </include>
    <!-- Pioneer2dx model -->
    <include>
      <uri>model://pioneer2dx</uri>
      <pose>0 0 0 0 0 0</pose>
    </include>
    <!-- A global light source -->
    <include>
      <uri>model://sun</uri>
    </include>
  </world>
</sdf>

Thanks to the expressiveness of player's error, I know that the file libgazebo_player does not exist (and indeed it is nowhere on my computer). Thus, the question is how do I install this additional library? Do I have to go through compiling gazebo 6.1 from sources as well or can I rely somewhat on the ubuntu repository?

For information:

$ > lsb_release -cd
Description:    Ubuntu 15.10
Codename:   wily

Thank you very much in advance for your help. Sincerely.

edit retag flag offensive close merge delete

Comments

I have the same issue with Gazebo 9.3.0 and Player 3.0.2.

tommy gravatar imagetommy ( 2018-08-04 09:36:12 -0600 )edit