Gazebo | Ignition | Community
Ask Your Question

Cannot connect to Connection Manager.

asked 2013-02-05 08:16:58 -0600

Morloth gravatar image

updated 2013-02-05 11:07:02 -0600

nkoenig gravatar image


I have followed the installation guide here: and installed Gazebo using the pre-compiled binaries for Ubuntu Linux 12.04 (precise). However, when I execute the following command:

bram@bram-progbak:~$ gazebo

I get the following output:

Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

Msg Waiting for master.Msg Waiting for master...................................................................................................

And the dots go on forever. When I hit CTRL-C the following messages is displayed: Error [] Connection Manager is not running

I have also tried to use the Gazebo package which is integrated with ROS but the same happens there. The following environmental variables have been defined:





Here is the tracelog when I try to run gzmaster:

bram@bram-progbak:~/builds/gazebo-1.4.0/build$ gdb gzmaster
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from /usr/local/bin/gzmaster...done.
(gdb) run
Starting program: /usr/local/bin/gzmaster 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".
[New Thread 0x7fffeceb9700 (LWP 5329)]
Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

Program received signal SIGSEGV, Segmentation fault.
gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/
65      this->connection->Listen(_port, boost::bind(&Master::OnAccept, this, _1));
(gdb) wher
#0  gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/
#1  0x000000000040f39b in main () at /home/bram/builds/gazebo-1.4.0/gazebo/

Hope you guys can help me get the master server to run. Thanks!


edit retag flag offensive close merge delete


Yes, I'm having the same problem.

logicalguy gravatar imagelogicalguy ( 2013-02-05 08:44:06 -0600 )edit

It seems that the problem is that when I run gzmaster it segfaults. (updated original post).

Morloth gravatar imageMorloth ( 2013-02-05 09:02:17 -0600 )edit

Just installed version Gazebo 1.3 which does work. So I'm not sure what the problem is with version 1.4.

Morloth gravatar imageMorloth ( 2013-02-05 09:49:47 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-02-05 12:17:02 -0600

Morloth gravatar image

updated 2013-02-05 12:17:50 -0600

Here you go, hope it helps.

bram@bram-progbak:~/gazebo_workspace/models/roomba$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:22:4d:51:ba:9d  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::222:4dff:fe51:ba9d/64 Scope:Link
          RX packets:5160510 errors:2 dropped:0 overruns:0 frame:1
          TX packets:1044009 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3180319676 (3.1 GB)  TX bytes:125889629 (125.8 MB)
          Interrupt:20 Memory:fe600000-fe620000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7990940 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7990940 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:6936528882 (6.9 GB)  TX bytes:6936528882 (6.9 GB)

bram@bram-progbak:~/gazebo_workspace/models/roomba$ hostname

bram@bram-progbak:~/gazebo_workspace/models/roomba$ domainname

bram@bram-progbak:~/gazebo_workspace/models/roomba$ cat /etc/hosts   localhost   bram-progbak

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
edit flag offensive delete link more


The short-term solution is to remove "localhost" from the "::1" line. I'm working on a patch to gazebo now.

nkoenig gravatar imagenkoenig ( 2013-02-05 12:32:50 -0600 )edit

Great! That worked, thank you very much.

Morloth gravatar imageMorloth ( 2013-02-06 06:06:03 -0600 )edit

answered 2013-02-05 11:08:54 -0600

nkoenig gravatar image

Can you please post the output of ifconfig, hostname, domainname, and the contents of /etc/hosts?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2013-02-05 08:16:58 -0600

Seen: 1,697 times

Last updated: Feb 05 '13