Gazebo | Ignition | Community
Ask Your Question

Gazebo launch error OSX 10.10.5

asked 2015-12-08 23:59:03 -0500

bender_rodriguez gravatar image

updated 2015-12-24 00:21:14 -0500

Hello, I followed the instructions to install gazebo on OSX but I get an error when running the command gazebo. I tried brew update and still get the same error. I've resolved the results from brew doctor and get the message: your system is ready to brew. I can't seem to find any log or figure a way to see what's going on behind the scene.

The other day I was getting the error message Segmentation Fault: 11 After running brew doctor I: Updated xCode to 7.1.1, deleted unexpected dylibs (libecomloadr.dylib), and updated homebrew

After running brew update today I got an error (Error. GUI Invalid arguments.)

I checked the OSX Console for system logs and see this entry below for gzserver and gzclient

Please help.

Process:               gzclient-6.5.1 [7793]
Path:                  /usr/local/Cellar/gazebo6/6.5.1/bin/gzclient-6.5.1
Identifier:            gzclient-6.5.1
Version:               ???
Code Type:             X86-64 (Native)
Parent Process:        gazebo-6.5.1 [7791]
Responsible:           Terminal [357]
User ID:               501
Date/Time:             2015-12-09 00:39:22.746 -0500
OS Version:            Mac OS X 10.10.5 (14F27)
Report Version:        11
Anonymous UUID:        6AD91210-C9EF-767D-8E9E-4B46BEE0329D
Time Awake Since Boot: 140000 seconds
Crashed Thread:        0  Dispatch queue:
Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0xfffffffffffffffb
VM Regions Near 0xfffffffffffffffb:
--> shared memory          00007ffffff9d000-00007ffffff9e000 [    4K] r-x/r-x SM=SHM  

Thread 0 Crashed:: Dispatch queue:
0   libboost_program_options-mt.dylib   0x0000000110f7c7b2 

*So I've taken this one as far as I can go this weekend. I think I see what's going on based on jason's answer below. I built the previous version of boost from source (1.58.0) since I didn't have that version already installed and after launching gazebo I got the error:*

dyld: Library not loaded: /usr/local/opt/boost/lib/libboost_thread-mt.dylib
  Referenced from: /usr/local/bin/gazebo
  Reason: image not found

I looked in the directory for /usr/local/opt/boost/lib/libboost_thread-mt.dylib and it's not there. It's not in the 1.58.0 directory, but it is in the original 1.59.0 directory. I tried to copy it to /usr/local/opt/boost/lib/ but still no luck.

I've done a bunch of stuff between then, installing the previous version 5 of gazebo, trying to install version 7, uninstalled gazebo, unlinked everything, uninstalled every keg one by one, uninstalled homebrew, then re-installed everything. I think I pretty well banjaxed the whole setup. Happy Holiday's everyone! Leaving DC and off to San Jose for the weekend!

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2015-12-21 18:21:13 -0500

jason gravatar image

I was able to work around this by switching back to the previous version of boost. In my case I had 1.58.0 already:

$ brew info boost
boost: stable 1.59.0 (bottled), HEAD
Collection of portable C++ source libraries
/usr/local/Cellar/boost/1.58.0 (10718 files, 486M)
  Poured from bottle
/usr/local/Cellar/boost/1.59.0 (10928 files, 454M) *
  Poured from bottle


$ brew switch boost 1.58.0
Cleaning /usr/local/Cellar/boost/1.58.0
Cleaning /usr/local/Cellar/boost/1.59.0
117 links created for /usr/local/Cellar/boost/1.58.0

And then I was back in business. Hope this works for you.

edit flag offensive delete link more


Thanks for the info! I'll give it a try this evening.

bender_rodriguez gravatar imagebender_rodriguez ( 2015-12-23 09:29:38 -0500 )edit

looks like only boost155 is latest available when I do brew search boost. It doesn't seem to allow me to switch to that either. I'll look at getting it from sourceforge and see if I can manually plop it in there. Heading out for the holiday so I'll get back to this next tuesday next week. Thanks again for the advice!

bender_rodriguez gravatar imagebender_rodriguez ( 2015-12-23 16:43:14 -0500 )edit

answered 2017-03-29 04:45:00 -0500

Thx a lot, saved me a tone of time. Jay

edit flag offensive delete link more

answered 2015-12-22 20:10:40 -0500

scpeters gravatar image

I've confirmed the error. We need to rebuild the gazebo6 bottles when new versions of boost are released. I'll start working on this...

edit flag offensive delete link more


Thank you!

bender_rodriguez gravatar imagebender_rodriguez ( 2015-12-23 09:30:41 -0500 )edit

Question Tools

1 follower


Asked: 2015-12-08 23:59:03 -0500

Seen: 1,184 times

Last updated: Dec 24 '15