Gazebo | Ignition | Community
Ask Your Question
0

E: Unable to correct problems, you have held broken package

asked 2016-01-09 07:34:38 -0600

wkyoun gravatar image

When I finished installing ROS Indigo, I noticed that it already came with Gazebo(version2.2.6). If I directly install the 6.0 Gazebo, is it possible that the 6.0 version and 2.2.6 version will conflict with each other?

Actually, I have tried to install gazebo as described in http://gazebosim.org/tutorials?tut=in...

but, it says that : E: Unable to correct problems, you have held broken package

It looks like that I have Gazebo(version2.2.6) cause this problem (gazebo which command indicate tha I have Gazebo(version2.2.6)

How can I remove Gazebo(version2.2.6) came with ROS indigo?

My situation is as follows:

wkyoun@wkyoun-XPS-13-9343:~$ sudo apt-get install gazebo6 Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: gazebo6 : Depends: libgazebo6 (= 6.5.1-1~trusty) but it is not going to be installed

       Depends: libsdformat3 but it is not going to be installed
       Depends: gazebo6-common (= 6.5.1-1~trusty) but it is not going to be installed
       Recommends: gazebo6-plugin-base

E: Unable to correct problems, you have held broken packages.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-01-15 13:01:21 -0600

Jose Luis Rivero gravatar image

gazebo6 from the OSRF repository declared conflict with gazebo2, so updating your system from just gazebo2 to gazebo6 should work out-of-the-box.

This situation is not the same if you have installed packages that depends on gazebo2 like ros-indigo-gazebo-ros-pkgs. What I would recommend, two options:

  1. Use aptitude (package manager, it propose solutions to conflict situations)

    apt-get install aptitude
    aptitude install libgazebo6-dev
    
  2. Clean up sdformat first, install later

    apt-get remove '.*sdf.*'
    apt-get install libgazebo6-dev
    

Both should resolve the situation.

edit flag offensive delete link more

Comments

used the remove sdf command. worked for me.

robot_commander gravatar imagerobot_commander ( 2017-03-20 13:55:14 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-01-09 07:34:38 -0600

Seen: 4,923 times

Last updated: Jan 15 '16