Gazebo | Ignition | Community
Ask Your Question

Box not moving in animated box tutorial

asked 2016-01-28 11:51:19 -0600

sm02 gravatar image

Hi there,

I'm trying to follow the animated box tutorial. When I run gazebo with, I see the box in the middle of the world but it does not move. Then when I try using the gz topic interface to view the pose, it comes up but doesn't have any pose information.

I'm using gazebo 5.1

edit retag flag offensive close merge delete


Can you run gazebo in verbose mode and see if you're getting any errors? `gazebo --verbose`

chapulina gravatar imagechapulina ( 2016-01-28 12:17:31 -0600 )edit

I just tried 'gazebo --verbose' and I received the following warnings and errors: [Wrn] [] Waited 1seconds for namespaces. [Err] [Plugin.hh:153] Failed to load plugin cannot open shared object file: No such file or directory

sm02 gravatar imagesm02 ( 2016-01-28 12:20:44 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-01-28 12:24:33 -0600

chapulina gravatar image

It seems that the plugin was not added to GAZEBO_PLUGIN_PATH, so Gazebo can't find it.

Be sure to move into your build folder and add it to the path like this:


As explained in the tutorial.

edit flag offensive delete link more


I had done that, but I just realized that I used ' instead of ` It works now, thank you!

sm02 gravatar imagesm02 ( 2016-01-28 12:35:20 -0600 )edit

What is the default value of $GAZEBO_PLUGIN_PATH, i guess I changed mine by mistake?

meha gravatar imagemeha ( 2016-02-23 14:50:00 -0600 )edit

I believe it is empty by default.

chapulina gravatar imagechapulina ( 2016-02-23 15:00:35 -0600 )edit

Yep, Thanks !!

meha gravatar imagemeha ( 2016-02-23 15:06:36 -0600 )edit

Question Tools

1 follower


Asked: 2016-01-28 11:51:19 -0600

Seen: 492 times

Last updated: Jan 28 '16