Gazebo | Ignition | Community
Ask Your Question

undefined symbol error in gazebo

asked 2016-02-04 18:37:19 -0600

dividkim gravatar image

I wanna make camera gazebo plugin so i tried to follow this tutorial

you can check that cpp source and .h files...

but it have some errors when i build it...

gzserver: symbol lookup error: /home/gwkim/light_sensor_ws/devel/lib/ undefined symbol: _ZN6gazebo20GazeboRosCameraUtilsC2Ev
[gazebo-2] process has died [pid 24539, exit code 127, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver --verbose -e ode /home/gwkim/light_sensor_ws/src/gazebo_light_sensor_plugin/worlds/ __name:=gazebo __log:=/home/gwkim/.ros/log/f9e256d6-caee-11e5-8656-001e6595291c/gazebo-2.log].
log file: /home/gwkim/.ros/log/f9e256d6-caee-11e5-8656-001e6595291c/gazebo-2*.log

i tried to serch its answer but i didnt find correct solution

i need your help.

im using 14.04 ubuntu and indigo version.

please answer here or send me e-mail please.

edit retag flag offensive close merge delete


What version of Gazebo and ROS are you using? The error you have posted looks like a run-time error, not a build error, right? My first guess would be your light sensor plugin cannot find the `GazeboRosCameraUtils` library. Make sure all the necessary plugins and libraries are in the correct paths.

nkoenig gravatar imagenkoenig ( 2016-02-05 11:12:47 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-05 18:14:52 -0600

scpeters gravatar image

I think the package needs to depend on gazebo_plugins also (add to catkin_create_pkg command, CMakeLists.txt, and package.xml).

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-02-04 18:37:19 -0600

Seen: 2,251 times

Last updated: Feb 05 '16