Gazebo | Ignition | Community
Ask Your Question
0

roslaunch RRBOT doesn't work [closed]

asked 2016-02-09 10:51:37 -0600

gabri89 gravatar image

Hi, I'm trying the example found here. I cloned the gazebo_ros_demos in my /src. I've no problems with

roslaunch rrbot_description rrbot_rviz.launch

But when I try to launch RRBot to Gazebo with :

roslaunch rrbot_gazebo rrbot_world.launch

it appears this on my screen:

core service [/rosout] found
process[gazebo-1]: started with pid [3477]
process[gazebo_gui-2]: started with pid [3481]
process[urdf_spawner-3]: started with pid [3485]
Traceback (most recent call last):
  File "/opt/ros/jade/lib/gazebo_ros/spawn_model", line 25, in <module>
    from gazebo_ros import gazebo_interface
  File "/opt/ros/jade/lib/python2.7/dist-packages/gazebo_ros/gazebo_interface.py", line 9, in <module>
    from gazebo_msgs.msg import *
ImportError: No module named msg
[ INFO] [1455036284.042904017]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1455036284.043749960]: waitForService: Service [/gazebo/set_physics_properties] has not been   advertised, waiting...
[urdf_spawner-3] process has died [pid 3485, exit code 1, cmd /opt/ros/jade/lib/gazebo_ros/spawn_model -urdf     -model rrbot -param robot_description __name:=urdf_spawner __log:=/home/gabriele/.ros/log/fd4ef6e0-cf48-11e5-a228-e839df8a64f0/urdf_spawner-3.log].
log file: /home/gabriele/.ros/log/fd4ef6e0-cf48-11e5-a228-e839df8a64f0/urdf_spawner-3*.log

Gazebo starts, but rrbot doesn't appear neither in the world, nor in the model database. I'm not able to understand if the error is in the file (like rrbot_world.launch, rrbot.world) or if I forgot to insert something in the bashrc file.

What am I missing here?

Bye

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by gabri89
close date 2016-05-06 04:19:52.726026

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-02-19 05:34:46 -0600

gabri89 gravatar image

I found the problem. There was a compatibility problem: replacing mi 6.5 version of gazebo with the 5.2 version the problem disappears.

Thank you.

edit flag offensive delete link more

Comments

Glad to know this :) As you solved the problem, you can close the question.

longforgotten gravatar imagelongforgotten ( 2016-02-19 06:28:04 -0600 )edit
0

answered 2016-02-11 07:55:41 -0600

longforgotten gravatar image

The traceback says that it couldn't find a module:

ImportError: No module named msg

Maybe you don't have the package gazebo_msgs. Try to check if ros_%YOUR_DISTRO_gazebo_msgs is installed in your machine.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2016-02-09 10:51:37 -0600

Seen: 840 times

Last updated: Feb 19 '16