Gazebo | Ignition | Community
Ask Your Question

Windows 8.1 installation hangs on configure step of gazebo code

asked 2016-02-17 06:30:13 -0500

snakeplisk gravatar image

Hello, I am having trouble installing Gazebo on Windows 8.1. I have Visual Studio 2013 and have installed everything to the tee as described here, and get as far as step 11, the configure step for the main gazebo code. What happens is cmake says Found ../../FreeImage-vc12-x64-release-debug/Source/FreeImage.h and then it hangs forever (I left it on all night and nothing happened). I independently compiled FreeImage in VS2013 and tried again, but same thing happens.

How do I get past this?

Also please do not suggest running in virtual linux as I have tried and it it much too slow for me. And I can't dual boot into linux for other reasons pertaining to my project. Thanks

edit retag flag offensive close merge delete


Just tried with version 6.1 and the exact same thing happens.

snakeplisk gravatar imagesnakeplisk ( 2016-02-17 06:46:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-02-17 11:05:44 -0500

snakeplisk gravatar image

updated 2016-02-26 13:31:23 -0500

EDIT: After a lot of playing around with this and getting nowhere, I asked on bitbucket and found someone who had already compiled it, and he was so kind as to branch his version with all edits included to get it to compile with VS2013

Give it a try

edit flag offensive delete link more


Now I've narrowed it down to protobuf, I had to replace the 2.6.0 vc12 version with 2.6.1 to get it to install in vs2013, now I get these linkage errors with protocompiler: [ 16%] Linking CXX executable gazebomsgs_out.exe : error LNK2019: unresolved external symbol "public: virt

snakeplisk gravatar imagesnakeplisk ( 2016-02-18 21:09:11 -0500 )edit

Unresolved: google::protobuf::io::Printer::~Printer(void), public: void __cdecl google::protobuf::io::Printer::Print , google::protobuf::compiler::cpp::GazeboGenerator::Generate,

snakeplisk gravatar imagesnakeplisk ( 2016-02-18 21:09:30 -0500 )edit

I know I'm pointing to the right lib files because it wouldnt even finish the configure stage without that

snakeplisk gravatar imagesnakeplisk ( 2016-02-18 21:11:22 -0500 )edit full error message If anyone has the Windows compiled version can they please host a torrent or upload it to MEGA?

snakeplisk gravatar imagesnakeplisk ( 2016-02-18 21:32:28 -0500 )edit

I also had issues with Protobug during the configure step (see [here]( I ended up solving it by downgrading CMake from 3.5.1 to 3.2.0. Now I'm stuck on "NMAKE : fatal error U1077" for the next command though...

Gama11 gravatar imageGama11 ( 2016-03-30 15:05:23 -0500 )edit

Had the same issue. Isnt there someone who solved it or can help?

TwoBid gravatar imageTwoBid ( 2016-04-21 06:33:33 -0500 )edit

Question Tools

1 follower


Asked: 2016-02-17 06:30:13 -0500

Seen: 633 times

Last updated: Feb 26 '16