Gazebo | Ignition | Community
Ask Your Question
0

Gazebo2 with black screen

asked 2016-03-02 00:04:37 -0600

ypfeng gravatar image

Hello all,

I just install gazebo2 on 14.04 Ubuntu. Everytime I run gazebo. It shows nothing but black screen or broken pics. Does the problem have something to do with the graphic card? I use Intel Broadwell integrated graphic.

image description

Thanks in advance

edit retag flag offensive close merge delete

Comments

Please, run by terminal with the command gazebo --verbose and feedback with the output.

leEngineer gravatar imageleEngineer ( 2016-03-06 06:58:23 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2016-03-08 10:01:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

I had the same problem as you! My configurations are:

lsb_release -a

Distributor ID: Ubuntu

Description: Ubuntu 14.04.1 LTS

Release: 14.04 Codename: trusty

lspci -k | egrep 'VGA|3D' -A2

00:02.0 VGA compatible controller:

Intel Corporation Broadwell-U

Integrated Graphics (rev 09)

Subsystem: Dell Device 0643 Kernel

driver in use: i915

After some research, I found this link which suggest to upgrade the kernel and graphical stack with the command:

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic

Gazebo started to "work" again, as you can see:

image description

I hope this answer can be helpfull.

Best regards

edit flag offensive delete link more
0

answered 2017-04-14 19:41:05 -0600

Thanks. This helps!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-02 00:04:37 -0600

Seen: 6,270 times

Last updated: Mar 08 '16