Gazebo | Ignition | Community
Ask Your Question

Models doesn't appear when setting up gazebo programmatically

asked 2016-03-10 01:33:57 -0500

XB32Z gravatar image

Hi everyone,

I tried the example animated_box which setup the server with a box inside.Then I launch the gzclient, it connect to the server and the box appears in the "models" but not on the render. I also tried to setup other models programmatically but they don't move (it's like they're not being simulated): they don't fall down for example (gravity flag is true in the model). Is there a way to make this work?

I'm working on Windows with gazebo 7 compiled in 32bits with Visual Studio 2013. Also unlike the tutorial I use the latest version of OGRE.

Thank you!


edit retag flag offensive close merge delete


it appears when gzclient is launch before publishing

XB32Z gravatar imageXB32Z ( 2016-03-10 09:26:00 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2016-03-29 09:52:41 -0500

XB32Z gravatar image

Sorry for the very late answer :/ I made my own branch available here: It hasn't been merged with the main because it doesn't compile under linux anymore. I guess that Gazebo is just not made for Windows ...

However I got it to work: launch the client before adding any models !

Thx for your help.

edit flag offensive delete link more


The order of launch sounds like the right solution. Side note: we still intend to get gazebo running on Windows eventually, so we would love if you could keep that windows branch up to date with master. Even if it doesn't compile on linux, we can work that part out. Windows contributions are super helpful for us!

Peter Mitrano gravatar imagePeter Mitrano ( 2016-04-01 13:02:05 -0500 )edit

Hi! I'm planing to make something cleaner soon :)

XB32Z gravatar imageXB32Z ( 2016-04-08 08:35:27 -0500 )edit

answered 2016-03-12 20:45:48 -0500

That's amazing to see that you got it running on windows!

I don't have the windows version right now. What commit are you at?

Here are some initial thoghts: Is simulation time increasing? does inserting a model from the insert tab work?

Maybe a video or some logs might help?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-03-10 01:33:57 -0500

Seen: 338 times

Last updated: Mar 29 '16