Gazebo | Ignition | Community
Ask Your Question

Virtual Machine not launching Gazebo

asked 2016-05-04 15:29:23 -0500

badrobit gravatar image

updated 2016-05-05 09:37:37 -0500

I am using the beta version of ROS as well as Ubuntu 16.04. When attempting to launch gazebo I get the following error:

mroscoe@ubuntu:~$ gazebo
VMware: vmw_ioctl_command error Invalid argument.

I have checked online and cannot find a solution and was hoping someone here may have run into it and knows how to work around it.

Results from running GLXGEARS:

mroscoe@ubuntu:~$ glxgears 
6223 frames in 5.0 seconds = 1244.564 FPS
4971 frames in 5.0 seconds = 993.205 FPS
6041 frames in 5.0 seconds = 1208.158 FPS
5833 frames in 5.0 seconds = 1166.566 FPS
5299 frames in 5.0 seconds = 1059.721 FPS
edit retag flag offensive close merge delete


Can you run `glxgears`?

chapulina gravatar imagechapulina ( 2016-05-04 18:00:09 -0500 )edit

Yes it runs with no issues (I attached the output to the question itself).

badrobit gravatar imagebadrobit ( 2016-05-05 09:37:05 -0500 )edit

the same issue: $ gazebo VMware: vmw_ioctl_command error Invalid argument

derek gravatar imagederek ( 2016-05-30 02:04:48 -0500 )edit

Clean/Fresh Ubuntu 16.04 and ROS Kinetic Kame install in VMware Fusion Professional Version 8.1.1 (3771013): Gazebo crashes with the same error message. "VMware: vmw_ioctl_command error Invalid argument."

Tim Dupont gravatar imageTim Dupont ( 2016-06-02 04:51:01 -0500 )edit

Can you try running `gzserver --verbose`? And then `gzclient --verbose`?

nkoenig gravatar imagenkoenig ( 2016-06-02 16:50:27 -0500 )edit

I have the same problem. I tried running glxgears and it worked. I also tried running 'gzserver --verbose' and then gzclient. gzserver --verbose ran perfectly but when i tried to ran gzclient --verbose i got this message: Aborted (core dumped) , and it crashed. Anybody knows how to fix the problems so that I can run gazebo?

jbongers gravatar imagejbongers ( 2016-06-15 04:40:48 -0500 )edit

Run gzclient in gbd, and post the backtrace.

nkoenig gravatar imagenkoenig ( 2016-06-15 10:49:21 -0500 )edit

Thnx for replying: I ran gzclien in gbd an this are my results: ( I give you the last 6 lines if this is OK?) VMware: vmw_ioctl_command error Invalid argument. [New Thread 0x7fff97fff700 (LWP 3792)] Thread 1 "gzclient" received signal SIGABRT, Aborted. 0x00007ffff647d418 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54 54 ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.

jbongers gravatar imagejbongers ( 2016-06-16 01:46:55 -0500 )edit

Hey. Please did you find a fix yet?

rash_einstein gravatar imagerash_einstein ( 2016-07-05 00:07:23 -0500 )edit

I've gotten then same error using gazebo (from ROS kinetic repos) on 16.04 in VMWare workstation 12.1.1. My host machine is a linux laptop with both nvidia and intel graphics. Interesting, I only see the problem when i have nvidia-prime set to the nvidia graphics.

jonbinney gravatar imagejonbinney ( 2016-07-07 01:44:34 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2017-01-14 10:55:17 -0500

MaEtUgR gravatar image

updated 2019-01-05 08:13:19 -0500

I had the same problem with:
Windows 8 host --> VMware 12.1.1 --> Ubuntu 16.04 guest
Gazebo 7.5

I solved it with the following environmental variable presumably shrinking down the graphics instruction set to OpenGL2.

$ export SVGA_VGPU10=0

Gazebo starts now and runs compared to the not 3D accelerated way pretty smooth on a T460p if the resolution of the VM guest system is not too high (<< 4K).

To make the change permanent use:

$ echo "export SVGA_VGPU10=0" >> ~/.profile

Sideote: If you'd add it to ~/.bashrc starting gazebo from gui or other terminals than bash would still be broken.

The entire idea is from Hugo Rodde, see .

edit flag offensive delete link more


this worked for me, VMWare 14 with Lubuntu + ROS Melodic and Gazebo 9. Sorry I dont have enough points to upvote your question.

aleangelico gravatar imagealeangelico ( 2019-01-05 19:30:39 -0500 )edit

Worked for me also. And unlike unchecking "accelerate Graphics", this solution keeps things fast! Thanks!

asantanna-applied gravatar imageasantanna-applied ( 2019-05-29 16:54:00 -0500 )edit

Agree, worked VMWare Fusion 10.1.6, Ubuntu 18.04.2, Gazebo 9.

BWMiller gravatar imageBWMiller ( 2019-06-12 13:12:00 -0500 )edit

answered 2016-07-10 20:33:35 -0500

m_elfar gravatar image

I was able to launch Gazebo 7.1.0 on Ubuntu 16.04 by unchecking "Accelerate 3D Graphics" option in the virtual machine settings. Seems like the problem has to do with how VMWare handles the graphics acceleration.

edit flag offensive delete link more


I tried your solution, and then it worked, the message "vmw_ioctl_command error Invalid argument" was gone. I have no idea why the "Accelerate 3D Graphics" has the impact on the issue. It just happens in Ubuntu 14 and higher version.

buckmole gravatar imagebuckmole ( 2016-08-27 09:34:28 -0500 )edit

Thanks it solved my problem of not being able to open fetch robot in gazebo simulation! It's strange tho, cause I actually can other robots except for that particular robot.

alienmon gravatar imagealienmon ( 2016-10-26 00:08:42 -0500 )edit

I've unselected the "Accelerate 3D Graphics" option, however, now when trying to log into the guest account, i just get a blank screen. has this happened to anyone else?

tabuzzy gravatar imagetabuzzy ( 2017-01-16 13:07:28 -0500 )edit

answered 2019-06-15 14:32:24 -0500

tjmzq8 gravatar image

I was using VMWare Player and getting VMware: vmw_ioctl_command error Cannot allocate memory sometimes when I tried to start Gazebo. I was able to fix the problem by going into the display settings for the virtual machine and increasing the amount of graphics memory to 2GB (you might be able to get a way with less).

edit flag offensive delete link more


This worked for me. Thanks

Adwait gravatar imageAdwait ( 2021-04-01 02:02:39 -0500 )edit

Question Tools



Asked: 2016-05-04 15:29:23 -0500

Seen: 97,626 times

Last updated: Jan 05 '19