Gazebo | Ignition | Community
Ask Your Question
0

The plugin SkidSteerDrivePlugin did not work on pioneer3at model in gazebo 5

asked 2016-05-16 04:16:54 -0600

Dengqing gravatar image

updated 2016-05-16 22:10:39 -0600

chapulina gravatar image

Hi,all: I added the plugin in pioneer3at model like this:

   <model name='pioneer3at'>
      ...
      <static>0</static>
      ...
      <plugin name='SkidSteerDrivePlugin' filename='libSkidSteerDrivePlugin.so'>
        <right_front>right_front</right_front>
        <right_rear>right_rear</right_rear>
        <left_front>left_front</left_front>
        <left_rear>left_rear</left_rear>
        <MaxForce>5.0</MaxForce>
      </plugin>
    </model>

But when I run the gazebo and then publish topic'~/pioneer3at/vel_cmd' using rqt_gui, the pioneer did not move.Also, any possible topic name has been tried. Anyone know why the pioneer did not move?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-05-17 10:48:46 -0600

chapulina gravatar image

Using rqt_gui, you're probably trying to publish to ROS topics, rather than Gazebo topics, which is what your plugin is subscribed to.

You can check the list of Gazebo topics with active publishers/subscribers with gz topic -l, and the list of ROS topics with rostopic list.

You can try writing a Gazebo publisher like this.

edit flag offensive delete link more

Comments

It works! Thanks!

Dengqing gravatar imageDengqing ( 2016-05-18 22:40:59 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-05-16 04:16:54 -0600

Seen: 349 times

Last updated: May 17 '16