About using ros_control in gazebo, I failed to commit the control command on my robot.

asked 2016-05-25 04:49:19 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I can get cmd_vel news form my velocity controller, but the robot in the simulator just do not respond. I tried both controlling by joystick and keyboard. The whole process of command transmission from the source to the controller worked successfully, and there were no errors reported.

So I find difficult to find out the reason of the result. There must be something I missed. Could any one please give me some instructions? I would be very grateful.

edit retag flag offensive close merge delete


How do you receive the cmd_vel in Gazebo ? Do you use a plugin (http://gazebosim.org/tutorials?tut=ros_gzplugins) ?

Brosseau.F gravatar imageBrosseau.F ( 2016-05-25 06:29:10 -0500 )edit

Yes. I have used the plugin. I have my packages here(git@github.com:YajingWang1994/ugvc_simulation.git). Could you lease check it and give a little more help? Thanks very much.

Yajing Wang gravatar imageYajing Wang ( 2016-05-25 07:12:00 -0500 )edit

I see that the gazebo skid steer driving plugin in ugvc_description/urdf/ugvc_crawler_robot.urdf.xacro is commentted. It is this plugin that will make your joints move and your robot move.

Brosseau.F gravatar imageBrosseau.F ( 2016-05-25 08:07:49 -0500 )edit

But actually I tried before adding comment on that part but also failed. I commented that part because I have already have a call for libgazebo_ros_control.so in ugvc_gazebo/urdf/description.gazebo.xacro,and for the type of the controller, ther is also parameters defined in control.yaml in ugvc_control/config/control.yaml? I thought the combination of <transmission> in ugvc_crawler_robot.urdf.xacro and the call for libgazebo_ros_control.so has the same function of the part you mentioned.

Yajing Wang gravatar imageYajing Wang ( 2016-05-25 08:23:06 -0500 )edit