Gazebo | Ignition | Community
Ask Your Question

Trouble importing SVG from tutorial

asked 2016-06-28 16:50:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.


I am having trouble importing the SVG file from the tutorial into gazebo recently installed on mac OSX.

When I select the SVG file from the gazebo GUI, the extracted path shows up correctly as in the tutorial, but once I click OK, it does not appear in the environment.

I have tried this with both my own SVG, and the file available on the tutorial page.

Thanks in advance if anyone can give me some pointers.

edit retag flag offensive close merge delete


Could you run Gazebo in verbose mode and add see if it shows any error messages? If so, please add them to your question. Also mention the Gazebo version you're using.

chapulina gravatar imagechapulina ( 2016-06-28 17:06:45 -0500 )edit

I am running version 7.2.0 After running verbose mode, I get the error message: [Err] [] GTS library not found. Can not extrude polyline

powertjp1 gravatar imagepowertjp1 ( 2016-06-28 17:17:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2016-06-28 22:42:06 -0500

chapulina gravatar image

updated 2016-06-29 10:52:20 -0500

Unfortunately, it looks like SVG extrusion is not working properly on OSX, see this issue.

edit flag offensive delete link more


I tried using *brew install gts* and building gazebo from source, but I still get the same error

powertjp1 gravatar imagepowertjp1 ( 2016-06-29 04:49:42 -0500 )edit

Ah sorry, I overlooked the fact you're using OSX. I updated the answer.

chapulina gravatar imagechapulina ( 2016-06-29 10:53:14 -0500 )edit

Ok, thanks for clarifying

powertjp1 gravatar imagepowertjp1 ( 2016-06-30 04:51:48 -0500 )edit

Question Tools

1 follower


Asked: 2016-06-28 16:50:42 -0500

Seen: 371 times

Last updated: Jun 29 '16