Gazebo | Ignition | Community
Ask Your Question
0

compiling gzweb with gazebo 7.3

asked 2016-07-12 21:40:11 -0500

lonewolf gravatar image

I tried compiling gzweb for the latest version of gazebo..

Gazebo multi-robot simulator, version 7.3.0 Copyright (C) 2012-2016 Open Source Robotics Foundation. Released under the Apache 2 License.

Node version v4.2.6

But I am unable to compile as it throws errors like

gzweb/tools/gzcoarse.cc:113:28: error: ‘const class gazebo::common::SubMesh’ has no member named ‘GetVertex’
     inVertex = _inSubMesh->GetVertex(i);

and this seems to be true as there doesn't seem to be any GetVertex in the Submesh? Does gzweb work with gazebo7 or should I downgrade?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-07-13 11:40:03 -0500

chapulina gravatar image
  1. GzWeb currently doesn't support new versions of Node, so you'll need to downgrade to 0.10 first. According to these instructions, first remove your current node:

    sudo apt-get remove nodejs
    

    then install the 0.10 version:

    curl -sL https://deb.nodesource.com/setup_0.10 | sudo -E bash -
    sudo apt-get install -y nodejs
    

    You can use similar instructions to go back to node 4 if you need to.

  2. The default branch of GzWeb has been compatible with Gazebo 7 for a while, but the latest "release" version 1.2.0 was not. I just created a new branch gzweb_1.3.0 from default, which should build against gazebo7. So you could just pull and use the new branch ;)

edit flag offensive delete link more

Comments

@chapulina Thanks a lot.. That worked great ..

lonewolf gravatar imagelonewolf ( 2016-07-13 18:30:13 -0500 )edit

gzweb_1.3.0 branch worked.

nzlz gravatar imagenzlz ( 2016-09-18 18:08:49 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-12 21:40:11 -0500

Seen: 545 times

Last updated: Jul 13 '16