Gazebo | Ignition | Community
Ask Your Question

Problem with launching the gazebo

asked 2016-08-24 02:57:07 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everyone,

I'm a new user in Gazebo, I had program to launch the gazebo in my Ubuntu 16.04.1 LTS 64bit system. It will stuck at preparing your world. It's this due to my computer's problem or some configuration problem?

image description

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2016-08-24 10:34:15 -0500

chapulina gravatar image

The first time you launch Gazebo, it tries to download some models from the internet. If you wait a while it will eventually start.

edit flag offensive delete link more


Thank you. you are right, I can use it now.

Zero.J gravatar imageZero.J ( 2016-08-25 21:24:44 -0500 )edit

How long do you have to wait? I have the same problem and have been waiting for hours.

spacejunkie gravatar imagespacejunkie ( 2017-01-31 01:11:05 -0500 )edit

It usually depends on your internet connection, but I don't think it should ever wait for hours.

chapulina gravatar imagechapulina ( 2017-01-31 10:39:53 -0500 )edit

having the same problem and I'v been wait for almost more than 2 hours for that normal?

Qdesign gravatar imageQdesign ( 2017-02-09 23:56:36 -0500 )edit

I have the same problem with gazebo 7.8 and ubuntu 16.04.3, somebody figured out how to fix it?

fmazzi gravatar imagefmazzi ( 2017-08-04 09:22:29 -0500 )edit

answered 2018-09-06 04:51:19 -0500

I also struggled with this behaviour. When I ran 'gazebo --verbose' it turned out the reason was that another gazebo server was running in the background:

[Err] [] EXCEPTION: Unable to start server[bind: Address already in use]. There is probably another Gazebo process running.

Checking the running processes (ps -x | grep gazebo) I found:

4525 pts/2 Sl 14:44 gzserver -s /opt/ros/kinetic/lib/ -s /opt/ros/kinetic/lib/

Killing this process (kill -9 4525) solved the problem.

edit flag offensive delete link more


I continue to have the same problem and there is no other process running. There must be a different reason for this occurrence. Something strange is being triggered by the empty_world.launch.

Starting the manual processes rosrun gazebo_ros gzserver rosrun gazebo_ros gzclient

Works fine.

Further answers are welcome.

juan gravatar imagejuan ( 2019-03-30 03:05:08 -0500 )edit

In order to kill the gazebo server I use pkill gzserver

desmond13 gravatar imagedesmond13 ( 2020-02-28 11:43:40 -0500 )edit

answered 2017-09-08 11:11:41 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I've run into this problem too, Ubuntu 16.04.2 LTS. I've clicked in 'preparing your world' window, it disapeared. Then ^C, shutdown gazebo, and relaunched the simulator: roslaunch turtlebot_gazebo turtlebot_world.launch. This time looks OK

edit flag offensive delete link more
Login/Signup to Answer

Question Tools



Asked: 2016-08-24 02:57:07 -0500

Seen: 12,807 times

Last updated: Sep 06 '18