GZWeb deploy hangs generating thumbnails

asked 2016-10-28 07:01:13 -0500

srees gravatar image

When running deploy -t, the first folder's thumbnails are generated, and it hangs almost immediately on the second folder with the following, and never comes back (I have to CTRL-C):

Warning [parser.cc:340] Converting a deprecated source[/home/sitl/gzweb/tools/../http/client/assets/arm_part/model.sdf].
Warning [Converter.cc:59]   Version[1.6] to Version[1.4]
  Please use the gzsdf tool to update your SDF files.
    $ gzsdf convert [sdf_file]
Error [Converter.cc:127] Unable to convert from SDF version 1.6 to 1.4
Msg Waiting for master
Msg Connected to gazebo master @
Msg Publicized address:
Error [Node.cc:90] No namespace found

I have tried running the gzsdf tool as it suggests and still get:

Error [Converter.cc:127] Unable to convert from SDF version 1.6 to 1.4

This is preventing me from being able to successfully install gzweb (at least usefully).

edit retag flag offensive close merge delete


Since there are LOTS of folders in here and the error occurs on a large number of them, I'm looking for a better solution than hand-modifying every single model.sdf and model.config...

srees gravatar imagesrees ( 2016-10-28 07:04:01 -0500 )edit

normally the sdf conversion tool will try convert the model to a higher (current) sdf version but it appears you're using sdf 1.4 which is older than the version of the model.sdf file (1.6). Maybe try taking out the `arm_part` model from the `http/client/assets` folder first and see if the sdf conversion error is what's causing the process to hang?

iche033 gravatar imageiche033 ( 2016-10-28 12:13:49 -0500 )edit

I'm also wondering if it's an issue with gazebo being version 2 in this particular case...I don't recall this issue on our other gazebo 6 installations.

srees gravatar imagesrees ( 2016-10-28 12:33:19 -0500 )edit