Gazebo | Ignition | Community
Ask Your Question

Boost not found when building Gazebo from source on Windows

asked 2016-11-11 03:34:15 -0500

Heziva gravatar image


The only way I've found to install Gazebo is to build it from source following this page:

I am stuck when I try to install sdformat: the windows command prompt says it cannot find boost. I do have boost in the directory its looking at. I've tried to download a more recent version of Boost and to alter configure.bat accordingly without success. I've tryed to set BOOST_ROOT and BOOST_LIBRARYDIR to the correct path in the console, doesn't change a thing.

How might I install Gazebo on my windows machine?

====== Finding 3rd Party Packages ======
-- Using internal tinyxml code
-- Operating system is Windows
-- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE)
-- Building for arch: x86_64
-- Boost version: 1.56.0
CMake Error at C:/Program Files/CMake/share/cmake-3.7/Modules/FindBoost.cmake:17
93 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.56.0

  Boost include path: D:/Jonathan/Gazebo/gz-ws/boost_1_56_0

  Could not find the following Boost libraries:


  No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to the
  directory containing Boost libraries or BOOST_ROOT to the location of
Call Stack (most recent call first):
  cmake/SearchForStuff.cmake:18 (find_package)
  CMakeLists.txt:107 (include)

--      Boost not found. Please install thread signals system filesystem program
_options regex boost version  or higher.
-- Could NOT find PY_psutil (missing:  PY_PSUTIL)
--      Python psutil package not found. Memory leak tests will be skipped
-- Found ruby executable: D:/Jonathan/prog/Ruby23-x64/bin/ruby.exe
-- ----------------------------------------
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-11-23 00:08:46 -0500

Vaidehi gravatar image

This error exists when the compiler is not able to find the "lib" folder in the boost directory. I had faced this same issue while installing Gazebo but it solved when I renamed the directory lib64-msvc-12.0 to lib.

Please go to the directory D:/Jonathan/Gazebo/gz-ws/boost_1_56_0 and check if there exists a folder that contains .dll as well as .lib files with names beginning as mentioned in the error message as

  • boost_system
  • boost_filesystem
  • boost_program_options
  • boost_regex
  • boost_iostreams

Rename that directory to lib and the ..\configure command will install sdformat without error.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2016-11-11 03:32:41 -0500

Seen: 1,369 times

Last updated: Nov 11 '16