Gazebo | Ignition | Community
Ask Your Question

gz log file won't run

asked 2016-11-22 18:04:56 -0500

shoemakerlevy9 gravatar image

updated 2016-11-23 11:24:25 -0500


I am trying to run diagnostics on a Gazebo log file that won't play back using gazebo -p state.log. I get the error:

[FATAL] [1479922107.060392505]: A ROS node for Gazebo has not been initialized, unable to load plugin. Load the Gazebo system plugin '' in the gazebo_ros package) [Err] [Plugin.hh:165] Failed to load plugin cannot open shared object file: No such file or directory

Running dpkg -S gives me:

ros-indigo-gazebo7-plugins: /opt/ros/indigo/lib/

and dpkg -S gives me:

gazebo7-plugin-base: /usr/lib/x86_64-linux-gnu/gazebo-7/plugins/

I see that its suggested to run gz log -i -f state.log in order to confirm that the log file is valid. I get:

Log Version: 1.0
Gazebo Version: 7.4.0
Random Seed: 1989963430
Size: 192.607 MB
Encoding: zlib

It was also suggested that I run the command tail -1 state.log and check to see if that outputs </gazebo> which it does.

Now I'm out of ideas on what to try next.

System info:
Gazebo 7
ROS Indigo
Ubuntu 14.04

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted

answered 2016-11-23 11:34:34 -0500

shoemakerlevy9 gravatar image

Running the command as a super user fixed the issue

sudo gazebo -p state.log --verbose
edit flag offensive delete link more

answered 2016-11-23 10:24:41 -0500

chapulina gravatar image

In order to get console output when running the log file, run gazebo in verbose mode:

gazebo -p state.log --verbose

For the gz log command, you must use the -f flag to specify the file like this:

gz log -i -f state.log

What exactly do you mean nothing happens when you playback the log file? On Gazebo7, when playing back a log file, the GUI should look different as shown on this tutorial (note the timeline on the bottom).

edit flag offensive delete link more


Following your advice about the -f flag worked and I've updated my post. When I said it did nothing I was running the command with a gazebo instance already running, it gave an error in the gazebo log file that I didn't see. Know i'm running the command without gazebo running first and am getting an error output to the terminal I ran the command in. I also added that to my post.

shoemakerlevy9 gravatar imageshoemakerlevy9 ( 2016-11-23 11:19:27 -0500 )edit

answered 2016-11-23 10:22:41 -0500

Carlos Agüero gravatar image

Try gz log -i -f state.log

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-11-22 18:04:56 -0500

Seen: 969 times

Last updated: Nov 23 '16