Gazebo | Ignition | Community
Ask Your Question

Mesh not displayed when launching with ROS

asked 2016-12-08 09:59:26 -0500

lelmac gravatar image


I created a cube with a texture in Blender, exported it as .obj and converted it with meshlab to .dae. I included the File in the world and works fine if I run it with gazebo <worldname>. But if I try running it with ROS, where i basically just included that world, the Object is not visible. ROS outputs also an errormessage, but I don't know if it's related to Problem.

Versions: Ubuntu 14.04, ROS Indigo, Gazebo 2.2.3

Only Gazebo: only gazebo

With Ros: image description

Errormessage:image description

If you need any further information, just let me know what you need. Any Help is appreciated.


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-12-12 06:56:26 -0500

lelmac gravatar image


I fixed it by placing the mesh and the texture into the .gazebo folder and using absolute paths to it.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2016-12-08 09:59:26 -0500

Seen: 1,238 times

Last updated: Dec 12 '16