Gazebo | Ignition | Community
Ask Your Question

gazebo7 trying to load

asked 2017-02-07 16:46:01 -0500

ckchow gravatar image

When I try to start gazebo 7, gzserver reports an error that it can't open I've installed from debs on ubuntu 16.04. I have checked ldconfig and the rest of my filesystem and I can't find any trace of libgazebo8.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-02-07 18:06:28 -0500

chapulina gravatar image

I imagine this is related to this question.

If you've mixed a lot of different source and deb install versions, I recommend you apt remove everything related to gazebo, ignition and sdformat, and make uninstall from the build directories. After that, dig around your /usr directory and delete anything related to gazebo, ignition and sdformat that you can find.

After all this you should be in a relatively clean state. But to be sure, when installing Gazebo 7 from debs, use the --reinstall flag:

sudo apt install gazebo7 --reinstall
edit flag offensive delete link more


I figured out that the busted source installs that I had done had created bad versions of gzclient and gzserver that were linked to libgazebo8. I had tried `make uninstall`, and it would probably have gotten rid of gzserver and friends, but the make commands were all broken because I had uninstalled libignition and some other dependencies already.

ckchow gravatar imageckchow ( 2017-02-09 14:04:37 -0500 )edit

Glad you solved the problem. This kind of thing happens to me all the time.

chapulina gravatar imagechapulina ( 2017-02-09 14:07:40 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2017-02-07 16:46:01 -0500

Seen: 289 times

Last updated: Feb 07 '17