Has anyone fixed the gpu_ray vertical ranges problem?

asked 2017-03-30 16:28:15 -0600

sebudge gravatar image

updated 2017-03-30 16:32:15 -0600

I am trying to use a gpu_ray sensor with both horizontal and vertical rays. I have to use the gpu_sensor because the ray sensor is unacceptably slow. I have run into the vertical ranges problem. Does anyone have a fix for this?

Are there any of the developers working on this problem?

The sensor is given as:

    <sensor name='laser' type='gpu_ray'>
      <pose frame='texsensor'>0 0 0 0 0 0</pose>
      <ray>
        <scan>
          <horizontal>
             <samples>419</samples>
            <resolution>1</resolution>
            <min_angle>-0.35</min_angle>
            <max_angle>0.35</max_angle>
         </horizontal>
          <vertical>
            <samples>8</samples>
            <min_angle>-0.05</min_angle>
            <max_angle>0.05</max_angle>
            <resolution>1</resolution>
          </vertical>
        </scan>
        <range>
          <min>1.0</min>
          <max>800</max>
          <resolution>0.01</resolution>
        </range>
      </ray>
      <always_on>true</always_on>
      <update_rate>10</update_rate>
      <visualize>true</visualize>
    </sensor>

The collision is with a heightmap.

When run in my simulation, the rays appear in the client, and the data message from the sim is sent to my listener. All of the data is correct except the ranges. The range values are duplicated along each horizontal line, and change for each vertical step.

When I run with only one vertical sample, the ranges are correct.

edit retag flag offensive close merge delete

Comments

I can ensure you the problem persists to this day. The problem was not solved and is still an issue in last version of Gazebo.

In fact I am using Gazebo 7.16 where is supposed to be fixed and the problems is still there.

Weasfas gravatar imageWeasfas ( 2019-11-15 06:30:45 -0600 )edit