Gazebo | Ignition | Community
Ask Your Question

YARP Gazebo clock plugin

asked 2017-04-03 09:37:41 -0500

SprGrf gravatar image

updated 2017-04-05 03:40:13 -0500

Hello everyone,

I would like to synchronize Simulink and Gazebo, and for that purpose I am trying to use the YARP clock plugin in combination with the WB-Toolbox for Simulink. However it seems that I cannot load it properly (from myrobot.gazebo file, also using a myrobot.xacro description), as the expected outputs do not appear. My setup includes ROS Kinetic and Gazebo 7.

Has anyone ever used this plugin successfully? Also is there any other way I might achieve synchronization ?

EDIT: Sorry for not clarifying these in the first place. This is the YARP clock plugin ( and this is the WB-Toolbox (, although the problem seems to originate in Gazebo. The myrobot.gazebo part where the plugin is loaded looks like this:

    <plugin name="gazebo_clock" filename="" />

This is a possible source of error as I have not found a similar example so I am not sure this is exactly how the plugin should be loaded.

As for the debug process, I have loaded the plugin both from the .gazebo file and using the command line, as MSI suggests below, however the result is the same. When I use the yarp name list command, the /clock port does not appear in the list. The result is that when I run the Simulink counterpart with the simulation synchronizer block I get an error message, mentioning that the block could not connect to the simulation clock server.

edit retag flag offensive close merge delete


Can you add links to the plugins you are referring to? Can you add the content of myrobot.gazebo to this question. Can you add more info about what is not loading properly? Finally, can you add all the debug steps you have taken?

nkoenig gravatar imagenkoenig ( 2017-04-04 09:25:24 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-04-04 03:13:20 -0500

MSI gravatar image

You can load the plugin by adding the option -s to the gazebo command:

gazebo -s

Then you can send rpc command on the port /clock (check if the /clock port is open with the command 'yarp name list')

example commands:

stepSimulation 1000
edit flag offensive delete link more


Thanks for your reply. Unfortunately, this does not seem to work. I tried to load the plugin both from the command line, using the command you mentioned, and the .gazebo file but the result was the same. The clock port does not appear in the list, as I mention on my edited question above.

SprGrf gravatar imageSprGrf ( 2017-04-05 03:42:33 -0500 )edit

try launching gazebo with the --verbose flag, and check whether it finds the plugin. Maybe you forgot to set the GAZEBO_PLUGIN_PATH environment variable.

MSI gravatar imageMSI ( 2017-04-11 03:58:25 -0500 )edit

Question Tools

1 follower


Asked: 2017-04-03 09:37:41 -0500

Seen: 450 times

Last updated: Apr 05 '17