Gazebo | Ignition | Community
Ask Your Question

Problem adding collada file

asked 2017-04-06 13:38:05 -0500

artuvd gravatar image

Hi all,

My name is Arturo, this is my first post.

I am trying to modify the turtlebot adding it a tag with texture made with Blender and exported as Collada file. I add the tag to the model like this:

<collision name="tag1_collision">
      <pose>0 0 0.44 0 0 0</pose>
            <size>0.4 0.2 0.01</size>
    <visual name="tag1_visual">
      <pose>0 0 0.44 0 0 0</pose>
        <diffuse>0 1 0 1</diffuse>

And when I try to run my world where this model is added, I is stacked here and nothing happens:

[Msg] Waiting for model database update to complete...
[Wrn] [] Queue limit reached for topic /gazebo/default/pose/local/info, deleting message. This warning is printed only once.

Any clue to fix this problem? The model has more .dae files which are in the same folder than the one i was created with blender.

Thanks in advance, cheers,


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-04-06 14:37:28 -0500

chapulina gravatar image

Hi Arturo,

It looks like Gazebo is not finding your model. Unfortunately, just starting Gazebo from inside the model's directory is not enough for the model to be found.

You need to add the root directory of your models (the parent directory of turtlebotJde2cam) to the GAZEBO_MODEL_PATH environment variable like this:

cd <path to root dir>

Also see this answer for more information

edit flag offensive delete link more


Thanks for your answer! I tried to add the model directory to the .bashrc like this: export GAZEBO_MODEL_PATH=$GAZEBO_MODEL_PATH:/usr/local/share/jderobot/gazebo/models:/home/projectfolder/text_test/gazebo/worlds/models And I tried to run it and I have this error: [Err] [] Unable to download model[model://turtlebotJde2cam/meshes/tagtext1.dae] [Err] [] File or path does not exist[""] [Err] [] No mesh specified

artuvd gravatar imageartuvd ( 2017-04-12 09:42:49 -0500 )edit

After you added this to bashrc, did you open a new terminal? It won't be valid for the current one. When you open Gazebo, can you see the paths you added listed on the insert menu on the left? Could you double check that `/home/projectfolder/text_test/gazebo/worlds/models/turtlebotJde2cam/meshes/tagtext1.dae` exists?

chapulina gravatar imagechapulina ( 2017-04-12 10:43:15 -0500 )edit

I did another test. I put the ArDrone in to my world with any modification. I've just copied the model from the original directory to my directory (/home/projectfolder/text_test/gazebo/worlds/models) and I changed the name of the copied folder to ArDrone_test. I did the necessary modifications in the world file and the model itself and similar error: [Err] [] Unable to download model[model://ArDrone2_test/meshes/quadrotor/quadrotor_4.dae]....

artuvd gravatar imageartuvd ( 2017-04-19 12:59:04 -0500 )edit

Question Tools

1 follower


Asked: 2017-04-06 13:37:41 -0500

Seen: 343 times

Last updated: Apr 06 '17