Gazebo | Ignition | Community
Ask Your Question
0

Error [Plugin.hh:180] libvelodyne_plugin.so: No such file or directory Gazebo 8.1.1

asked 2017-06-17 11:48:40 -0500

michael1234 gravatar image

I am following this tutorial: http://gazebosim.org/tutorials?tut=gu...

When I run Gazebo:

gazebo --verbose ../velodyne.world

This error appears:

[Err] [Plugin.hh:180] Failed to load plugin libvelodyne_plugin.so: libvelodyne_plugin.so: cannot open shared object file: No such file or directory

How can I fix this?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-06-17 11:53:06 -0500

michael1234 gravatar image

What is happening is that Gazebo can't find libvelodyne_plugin.so, this look for libraries in the directories indicate by LD_LIBRARY_PATH enviromental variable, so you need to indicate where to find it changing it.

export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:~/velodyne_plugin/build
edit flag offensive delete link more
0

answered 2020-11-26 11:15:47 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

for gazebo11 make the link to the plugin like this './libvelodyne_plugin.so' in the .world file

edit flag offensive delete link more

Comments

That is the case. Thank you! The code on the tutorial missed './'.

T_T gravatar imageT_T ( 2021-04-27 20:57:13 -0500 )edit

It worked for me!! Thanks a lot!

ssanchez37 gravatar imagessanchez37 ( 2021-05-31 15:54:58 -0500 )edit

Gracias, amigo.

Joabsuza gravatar imageJoabsuza ( 2021-12-18 10:25:32 -0500 )edit

Thank you bro, it also worked for me. For all the users that have the same problem, you just need to copy and replace the next code line in your velodyne.world file.

<!-- Attach the plugin to this model -->
<plugin name="velodyne_control" filename="./libvelodyne_plugin.so"/>
LuisEFA1998 gravatar imageLuisEFA1998 ( 2022-03-14 16:59:08 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2017-06-17 11:48:40 -0500

Seen: 5,910 times

Last updated: Jun 17 '17