Error due to update Gazebo2 to Gazebo5

asked 2017-06-30 02:50:53 -0500

Akitoshi gravatar image

Hello, I have started using ROS for my research in my university.

My computer had ROS (indigo) with Gazebo2 in the first. I had to use fish-eye camera with URDF which needs sdf ver1.5 or newer version. Therefore, I have updated my Gazebo2 to Gazebo5 and now trying with ROS(indigo).

However, there is the following error:

* Error in `gzserver': double free or corruption (out): 0x00007f506476ffe0 Aborted (core dumped)
[gazebo-2] process has died [pid 3582, exit code 134, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver -e ode /home/ito/catkin_ws/src/sample_gazebo/worlds/ __name:=gazebo __log:=/home/ito/.ros/log/35d739bc-5c76-11e7-9c70-d017c28b9326/gazebo-2.log]. log file: /home/ito/.ros/log/35d739bc-5c76-11e7-9c70-d017c28b9326/gazebo-2

it seems like there is problem with gzserver, but I have no idea how to fix this. If you have any solutions to this, it would be pleasure to know the answer. Thank you.

edit retag flag offensive close merge delete


The error you pasted doesn't contain much information, maybe you can add a backtrace to your question? In any case, I recommend you update to Gazebo 7 instead, which is the current LTS. Gazebo 5 is no longer supported. Here is a helpful guide:

chapulina gravatar imagechapulina ( 2017-06-30 11:39:08 -0500 )edit

@chapulina About the error, it showed the code above only. I guess it was some sort of bug? But thank you for your recommendation! I updated to Gazebo 7 and it works now!

Akitoshi gravatar imageAkitoshi ( 2017-07-01 06:03:35 -0500 )edit

You should try Gazebo7 EDIT : I didn't see chapulina answer, nice if it worked :)

blevesque gravatar imageblevesque ( 2017-07-03 10:20:31 -0500 )edit