Is there a file size limit on .stl files uploaded into the model editor, or is it entirely based on your computers hardware?

asked 2017-07-10 15:34:56 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am currently trying to build a test ground for a robot. I am able to load in small .stl files into the model editor for custom objects. When I try to add larger files Gazebo will crash, and I will have to restart my computer to get Gazebo running again. Is there a maximum file size for .stl files that can be loaded into editor? Is there a workaround for me to load a pretty hefty building into the model editor with out gazebo crashing? Is it a hardware issue? The smaller .stl files show up orange almost immediately. The larger files make the computer think for a minute, and then it dies. What can I do to fix this?

edit retag flag offensive close merge delete


Have you tried running Gazebo in verbose mode and seeing if any errors are printed out?

chapulina gravatar imagechapulina ( 2017-07-10 19:13:33 -0600 )edit

I have, and no errors are thrown. Gazebo will just crash, and then it wont load again until after a restart. I working with a Mac Server that has 12 core processor, and 128 gigs of Ram, but it does not have a dedicated graphics card.

RobotsrCool gravatar imageRobotsrCool ( 2017-07-11 09:11:10 -0600 )edit

This sounds like a bug. It would be helpful if you managed to get a backtrace and then ticket an issue about this.

chapulina gravatar imagechapulina ( 2017-07-11 09:25:25 -0600 )edit

I realized the .STL file I was using was scaled using feet. I re-exported the .stl file using meters as the unit, and they loaded the files.

RobotsrCool gravatar imageRobotsrCool ( 2017-07-11 11:18:58 -0600 )edit

Glad to hear it worked out. Still, Gazebo should not crash when models are badly scaled :/

chapulina gravatar imagechapulina ( 2017-07-11 11:33:22 -0600 )edit