Blendmode add for material in collada file for gazebo

asked 2017-07-25 09:59:44 -0600

elchtest gravatar image

Hi,

I am trying to get a model of a tree working in gazebo. It uses a 32-bit png texture with RGB and an alpha channel which defines where the leaf should be cut off (Alpha to Coverage).

In the Collada .dae file this is defined as:

          <texture texture="Map #10-image" texcoord="CHANNEL0">
            <extra>
              <technique profile="MAYA">
                <wrapU sid="wrapU0">TRUE</wrapU>
                <wrapV sid="wrapV0">TRUE</wrapV>
                <blend_mode>ADD</blend_mode>
              </technique>
            </extra>
          </texture>

Some public mesh viewers display it correctly. In gazebo, there is no blending shown. When I select the object in gazebo, view - show transparent, then the alpha channel looks correct, but now the opaque parts of the tree and the bark are transparent as well.

What is the best way to do this correctly when loading from collada files?

Thanks!

edit retag flag offensive close merge delete