Gazebo | Ignition | Community
Ask Your Question

Could not find a package configuration file provided by "gazebo" with any of the following names:gazeboConfig.cmake gazebo-config.cmake

asked 2017-09-07 12:43:17 -0600

Ji Cai gravatar image

What should I do to solve this problem?image description

edit retag flag offensive close merge delete


Same issue......I have even installed Libgazebo5-dev ...but same error....Can anybody help on this please?

GORO_CHAT gravatar imageGORO_CHAT ( 2018-07-22 12:10:26 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-09-07 12:58:53 -0600

sloretz gravatar image

Which version of gazebo is installed? Find out using gazebo --version. For example, I have gazebo 7.

$ gazebo --version
Gazebo multi-robot simulator, version 7.7.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.

You'll need the the dev package for that version of gazebo. For gazebo 7 run sudo apt install libgazebo7-dev.

You can find more information about setting up a computer to build plugins in the first few sections of this tutorial

edit flag offensive delete link more


I have solved this problem by following the installation tutorial, and 'sudo' the basic files. Thank you for your help.

Ji Cai gravatar imageJi Cai ( 2017-09-07 13:05:31 -0600 )edit

I have installed Libgaebo5-dev but still the error is same. What could be the reason?

GORO_CHAT gravatar imageGORO_CHAT ( 2018-07-22 01:51:27 -0600 )edit

Even after installing libgazebo4-dev, the error remained the same on indigo ros+Gazebo 5

GORO_CHAT gravatar imageGORO_CHAT ( 2018-07-22 12:08:47 -0600 )edit
Login/Signup to Answer

Question Tools



Asked: 2017-09-07 12:43:17 -0600

Seen: 10,518 times

Last updated: Sep 07 '17