Home | Tutorials | Wiki | Issues
Ask Your Question
2

symbol lookup error with latest gazebo(1.5.0-1~precise)/drcsim(2.1.0-1~precise) from .debs

asked 2013-03-12 04:51:48 -0500

Stefan Kohlbrecher gravatar image

updated 2013-03-12 04:54:43 -0500

Since I (apt-get) upgraded, I get

gazebo: symbol lookup error: /usr/lib/drcsim-2.1/plugins/libgazebo_ros_api_plugin.so: undefined symbol: _ZN6gazebo9transport9PublisherC1ERKSsS3_j

with gazebo(1.5.0-1~precise)/drcsim(2.1.0-1~precise) installed from .debs on my Ubuntu 12.04/AMD64 machine. It ran without problems before, so this appears to be a bug. Is this happening to anyone else?

/edit: Happens for example when starting default atlas:

roslaunch atlas_utils atlas.launch
edit retag flag offensive close merge delete

Comments

I can reproduce this in a 12.04 32bit system. It was also the case with the prerelease binaries from the last couple of days. The problem is on the drcsim side. I built drcsim (2.2) from source and got it to work, though. You beat me to posting the question :-)

Adolfo Rodríguez T gravatar imageAdolfo Rodríguez T ( 2013-03-12 06:23:41 -0500 )edit

A minimal test to reproduce is to run gazebo -s libgazebo_ros_api_plugin.so

Adolfo Rodríguez T gravatar imageAdolfo Rodríguez T ( 2013-03-12 07:14:35 -0500 )edit

Got similar problem here. Cant start Gazebo now after today's update....

Luis Filipe Rossi gravatar imageLuis Filipe Rossi ( 2013-03-12 09:37:45 -0500 )edit

Getting same errors

danny.brown gravatar imagedanny.brown ( 2013-03-12 18:39:09 -0500 )edit

HI. I got the same message. Did you fixed it?

gazer gravatar imagegazer ( 2013-05-20 00:15:36 -0500 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2013-03-12 10:04:44 -0500

gerkey gravatar image

updated 2013-03-12 19:03:58 -0500

Looks like you were unlucky enough to update in between the release of gazebo 1.5.0 and drcsim 2.2.0.

We're working through the drcsim 2.2.0 release now and expect it to be out soon.

In the meantime, I suggest that you roll back your gazebo installation by grabbing a 1.4.0 .deb from the archive, e.g. something like should do the trick on a 64-bit machine:

wget http://gazebosim.org/assets/distributions/gazebo_1.4.0_amd64.deb
sudo apt-get remove -y gazebo gazebo-prerelease
sudo dpkg -i gazebo_1.4.0_amd64.deb
sudo apt-get install -y drcsim
edit flag offensive delete link more

Comments

How do I roll back the installation?

danny.brown gravatar imagedanny.brown ( 2013-03-12 18:39:25 -0500 )edit

I updated my answer to provide a technique.

gerkey gravatar imagegerkey ( 2013-03-12 19:04:50 -0500 )edit
1

answered 2013-03-12 19:07:13 -0500

gerkey gravatar image

drcsim 2.2.0 has been released. So you should be able to fix your system like so:

sudo apt-get update
sudo apt-get install drcsim
edit flag offensive delete link more

Comments

When will it be released for precise i386?

superawesomepanda gravatar imagesuperawesomepanda ( 2013-03-12 19:15:52 -0500 )edit

Starting with drcsim 2.2.0, we're incorporating the AtlasBehaviorLibrary from Boston Dynamics, which provides walking and balancing control of the Atlas robot. This library is provided to us as a binary-only shared object, and is currently available only in 64-bit. Until that changes, we won't be building drcsim for 32-bit machines. You can build from source on a 32-bit machine if you exclude the AtlasBehaviorLibrary.

gerkey gravatar imagegerkey ( 2013-03-12 23:23:11 -0500 )edit

@gerkey: found the answer to my question on the other thread. We need to post that DRCsim now requires a 64-bit system. Advise that this be placed under a 'requirements' page for DRCsim, which I believe is currently absent.

DRC_Justin gravatar imageDRC_Justin ( 2013-03-21 15:17:51 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-03-12 04:51:48 -0500

Seen: 471 times

Last updated: Mar 12 '13