Gazebo | Ignition | Community
Ask Your Question

heightmap insertion unsuccessful with gazebo 7

asked 2017-11-30 21:44:26 -0500

bitpejoy gravatar image

I want to use heightmap created by myself in gazebo, and I`ve followed tutorials like this one and this. I use Ubuntu 16.04 and gazebo 7 as the second tutorial requires.

At first , I created a heightmap as the first tutorial instructed, and I tested with my gazebo. It worked out, though occasionally the heightmap wasn't loaded fully . Only half of the terrain was loaded, and the other half was flat.

But after a few hours I tried again. But no matter how I try , my gazebo always crashes after I insert heightmap. And the error msg is always the same:

gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:648: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.

I've checked a question asked by others before.But is there any better solution to this problem? Updating gazebo to 8 may work, but it's not convenient and the tutorials insert heightmap with gazebo 7 successfully.

Thanks in advance.

edit retag flag offensive close merge delete


Can you try using gazebo 7.7? There are instructions in the question you linked to. I assume you are using a large image for the heightmap. Can you try using a smaller image?

nkoenig gravatar imagenkoenig ( 2017-12-01 09:57:55 -0500 )edit

My image is 129x129. Gazebo 7.9 works. Thanks.

bitpejoy gravatar imagebitpejoy ( 2017-12-01 20:17:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-02 02:58:08 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Update gazebo to the 7.9.

get OSRF keys, and then sudo apt upgrade.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-11-30 21:06:04 -0500

Seen: 782 times

Last updated: Dec 02 '17