gazebo crashing when lauching turtlebot ( docker container )

asked 2017-12-07 09:25:03 -0600

benjaminklingeleers gravatar image

updated 2017-12-07 11:55:33 -0600

chapulina gravatar image

I installed a docker container with gazebo


After this i installed ros kinetic on the container. I want to launch robots ( turtlebot in this case ) so they go in gazebo.

When i run roslaunch turtlebot_gazebo turtlebot_world.launch i get the next error.

[gazebo-2] process has died [pid 21045, exit code 255, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /opt/ros/kinetic/share/turtlebot_gazebo/worlds/ __name:=gazebo __log:=/root/.ros/log/e3d818a2-db5f-11e7-b4d8-0242ac110002/gazebo-2.log]. log file: /root/.ros/log/e3d818a2-db5f-11e7-b4d8-0242ac110002/gazebo-2*.log process[mobile_base_nodelet_manager-5]: started with pid [21117] process[cmd_vel_mux-6]: started with pid [21130] process[bumper2pointcloud-7]: started with pid [21161] process[robot_state_publisher-8]: started with pid [21244] process[laserscan_nodelet_manager-9]: started with pid [21293]

Any help on how to fix this is really appreciated

edit retag flag offensive close merge delete


some hints to debug the problem: does the docker image defines a DISPLAY? what is the output of echo $DISPLAY? Let's start first by trying to run gazebo alone wihtout ROS. What does gazebo --verbose display? Please edit the answer and add the information.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2017-12-07 12:29:56 -0600 )edit

ECho $display returns :0 Gazebo verbose : [Err] [] EXCEPTION: Unable to start server [bind: Address already in use]. There is probably another Gazebo process running. However, when i do gzclient it launches a gazebo client what works. When i run ps ax i see gzserver running with PID 1. Even when i do kill -9 1 its still there next time. Edit : i exported the gazebo master ip and gazebo master uri to now i get the next output :

benjaminklingeleers gravatar imagebenjaminklingeleers ( 2017-12-08 01:39:40 -0600 )edit

Even tho the verbose process works i still cant launch

benjaminklingeleers gravatar imagebenjaminklingeleers ( 2017-12-08 02:10:06 -0600 )edit

looks like there is a gzserver process floating around somehow. I would start by debugging where (in the container or in the host), kill it and launch the process again until getting it working or a different error.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2017-12-28 17:28:41 -0600 )edit