Gazebo | Ignition | Community
Ask Your Question

GetVelocity returns absurd values in Gazebo 7 and ROS Kinetic

asked 2018-02-01 01:38:24 -0500

mark_vision gravatar image

updated 2018-02-01 09:16:30 -0500

Hi all, after the upgrade to ROS Kinetic and Gazebo 7 my quadruped robot (hyq, URDF available here) returns unrealistic values for the joint velocities.

When the robot is static:

when the robot is static

I see a velocity of 0.68 rad/s (or deg/s the documentation is unclear :( whereas the exact same code (a copy of this one) correctly returns almost zero values in Gazebo 2.2

Any known issue about this?

Attached is the output of gz model -m hyq -i



The problem occurs in Gazebo8 as well :(

Maybe is something related to the robot model?


I somewhat mitigated the problem by setting the <maxVel> tag to 1.

However, when the joints are perfectly static, the velocity is still around 0.004 rad/s

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2022-11-10 08:57:16 -0500

Hi @mark_vision,

how do you set the maxVel attribute? do you call the method of the Joint class setParam? Have you found a better solution to this problem in the meantime?

I am asking this since in Gazebo 11 I found the same problem.


edit flag offensive delete link more

Question Tools



Asked: 2018-02-01 01:38:24 -0500

Seen: 250 times

Last updated: Nov 10 '22