Gazebo | Ignition | Community
Ask Your Question

Cannot compile any plugins in Gazebo 7.9

asked 2018-02-13 12:20:44 -0500

chcoui gravatar image

I'm trying to learn gazebo by following the tutorials and i got stuck on this one :

On step 5, when i run make, i'm getting the following

    charles@A530-10l:~/velodyne_plugin/build$ make
[ 50%] Building CXX object CMakeFiles/velodyne_plugin.dir/
In file included from /usr/include/gazebo-7/gazebo/gazebo_core.hh:21:0,
                 from /usr/include/gazebo-7/gazebo/gazebo.hh:20, 
        from /home/charles/velodyne_plugin/
    /usr/include/gazebo-7/gazebo/msgs/msgs.hh:24:37: fatal error: ignition/math/Inertial.hh: No such file or directory
    compilation terminated.
    CMakeFiles/velodyne_plugin.dir/build.make:62: recipe for target 'CMakeFiles/velodyne_plugin.dir/' failed
        make[2]: *** [CMakeFiles/velodyne_plugin.dir/] Error 1
        CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/velodyne_plugin.dir/all' failed
        make[1]: *** [CMakeFiles/velodyne_plugin.dir/all] Error 2
    Makefile:83: recipe for target 'all' failed
    make: *** [all] Error 2

I'm running Gazebo 7.9, on Ubuntu 16.04 with Ros Kinetic. The problem seems to be with the ignition/math/Inertial.hh header-file that do not exist... When i do locate Inertial.hh. I get the following /usr/include/gazebo-7/gazebo/physics/Inertial.hh.

Any idea??

Thanks Charles

edit retag flag offensive close merge delete


Hi Charles, I have the same Problem using gazebo. Did you solve the problem? I created a new Gazebo Model PlugIn and when I try catkin build, I get the same error. Thanks!

Luna2005 gravatar imageLuna2005 ( 2018-10-18 04:18:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-10-18 12:43:21 -0500

chapulina gravatar image

The missing header is from the Ignition Math library, not the one from Gazebo physics.

I recommend you clean up your installation and install Gazebo again (the latest version is 7.14, so you're a few behind). That should also pull in the correct Ignition Math version.

edit flag offensive delete link more

answered 2019-04-10 21:30:41 -0500

juan gravatar image

Installing the library helped resolve the problem: sudo apt-get install libignition-math2-dev

edit flag offensive delete link more

Question Tools



Asked: 2018-02-13 12:20:44 -0500

Seen: 2,075 times

Last updated: Apr 10 '19