Gazebo | Ignition | Community
Ask Your Question

gazebo-9 gui doesn't launch

asked 2018-03-08 10:45:39 -0500

Robert Brothers gravatar image


I recently un-installed my copy of gazebo 7 that came with my installation of ros kinetic (desktop full) on my Ubuntu 16.04 system. It was crashing on launch and I attributed that to this issue based on Sharvashish Das's comment (I could have been totally wrong but I didn't really document my error tracking process.) I knew I needed to upgrade to gazebo 9 at some point anyway (project reasons) so I decided to install it from source based on the tutorial here. I also installed the dependent libraries from source as the tutorial suggested. I made sure that ros was not sourced during this whole process as the tutorial suggests.

Everything built and was installed in my usr/local/ directory. However, when I tried to launch gazebo it did nothing.

I tried to run the executable directly from usr/local/bin and still nothing

It seems that I can launch the gzserver executable. Here is the verbose output:

But I get a Segmentation fault (core dumped) output from the gzclient:

I read somewhere that this error could be fixed by installing the latest proprietary Nvidia drivers. I have a Nvidia GTX-970 graphics card, and found that the latest driver was the nvidia-390.25. I installed it, and made sure it was running:

but I'm still getting the same results. I'm not really sure what to do next. Try un-installing and re-installing? Un-install ros and gazebo and re-install gazebo-9 first? Is there something obvious I'm missing and I can avoid that all together?

As a side note. The install from source tutorial has you download and build everything from the /tmp directory, and then says to do sudo make uninstall from the build directory if you want to un-install. In my case, those directories got wiped when I had to reboot for the graphics drivers to update. I made local copies of these directories before I rebooted, but I'm still confused as to why they would have you do all this in the /tmp folder in the first place? I'm still somewhat new to Linux and don't do much building from source, so maybe that's a newbie question.

edit retag flag offensive close merge delete


Good point about the `/tmp` dir, it would be great if you could send a change to gazbeo_tutorials:

chapulina gravatar imagechapulina ( 2018-03-08 18:24:57 -0500 )edit

Good point about the `/tmp` dir, it would be great if you could send a change to gazebo_tutorials:

chapulina gravatar imagechapulina ( 2018-03-08 18:25:18 -0500 )edit

Thank you!

chapulina gravatar imagechapulina ( 2018-03-09 10:00:10 -0500 )edit

Hi, did you manage to solve the problem? I am facing exactly the same one. It seems when running the gzclient in gdb mode, the segmentation fault comes from Qt4: Program received signal SIGSEGV, Segmentation fault. 0x00007fffe8d795a4 in ?? () from /usr/lib/x86_64-linux-gnu/

gpldecha gravatar imagegpldecha ( 2018-07-19 15:02:00 -0500 )edit

No, I never did get it working and just reverted back to gazebo-7 for the time being. I'm working on a different machine now and probably won't try gazebo-9 until my whole lab migrates away from ros-kinetic. This is a total shot in the dark, but do you have the right version of libqtgui? Might be related to this issue:

Robert Brothers gravatar imageRobert Brothers ( 2018-07-19 16:19:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-07-20 04:34:18 -0500

gpldecha gravatar image

I have had the same problem on two separate ubuntu 16 computers. The solution to this problem is related to the answer given in gazebo-client-on-debian-crashes-at-startup/.

That is the culprit here is libqwt. Here are the steps I took to get it working.

  1. remove everything related to libqwt.
  2. install libqwt-qt5

After building and install gazebo I checked what libraries are linked to gazebo:

PATH_TO_GAZEBO_INSTALL/lib$ ldd * | grep libqwt => /usr/lib/ (0x00007ffac85df000) => /usr/lib/ (0x00007ff565b6b000) => /usr/lib/ (0x00007fa1c1724000)
edit flag offensive delete link more

Question Tools



Asked: 2018-03-08 10:45:39 -0500

Seen: 6,779 times

Last updated: Jul 20 '18