Can't compile FreeImage with visual studio 2017 [closed]

asked 2018-04-16 04:55:24 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I tried to install FreeImage (the one given on the tutoriel for windows: on windows, but when I try to build the project I have 3 fail (with FreeImage.2008.vcxproj, LibTIFF4.2008.vcxproj and LibRawLite.2008.vcxproj).

I didn't touch the code, so I don't know why there are some fail. Is it because I use visual studio 2017 and not 2013? Or do I miss something?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by geoffrey
close date 2018-05-09 06:21:09.518889


I've never tried to run Gazebo on Windows (it may be possible), but that tutorial starts out with the statement *"This documentation describes how to set up a workspace for trying to compile Gazebo on Windows. It does not actually work yet."* Whether or not that is still accurate, I don't know. Just pointing out for your consideration :)

josephcoombe gravatar imagejosephcoombe ( 2018-04-16 14:06:28 -0500 )edit

I saw it after asking this question. The tutoriel also said that it was test on Windows 7 and 8.1 but not for 10 (they didn't wrote for windows 10). But I will do my best to compile Gazebo on windows 10.

geoffrey gravatar imagegeoffrey ( 2018-04-17 03:18:48 -0500 )edit

Cool, be sure to update your question if you figure it out! Hopefully someone who's tried it before will be able to help.

josephcoombe gravatar imagejosephcoombe ( 2018-04-17 08:18:28 -0500 )edit